summaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/image
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-01-11 04:44:45 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-01-11 04:44:45 +0000
commit541158d5ad4a941d927a397737b6588d2e4db22d (patch)
treee49a97f18123413611824b8993e9acff9d681bae /target/linux/xburst/image
parentdb06ca593b3d80ec514ecb2b20d49e3638cd3f0b (diff)
downloadmaster-31e0f0ae-541158d5ad4a941d927a397737b6588d2e4db22d.tar.gz
master-31e0f0ae-541158d5ad4a941d927a397737b6588d2e4db22d.tar.bz2
master-31e0f0ae-541158d5ad4a941d927a397737b6588d2e4db22d.zip
Merge xburst target.
SVN-Revision: 19098
Diffstat (limited to 'target/linux/xburst/image')
-rw-r--r--target/linux/xburst/image/Makefile28
-rw-r--r--target/linux/xburst/image/ubinize.cfg14
2 files changed, 42 insertions, 0 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
new file mode 100644
index 0000000000..dcc97e7657
--- /dev/null
+++ b/target/linux/xburst/image/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=256k 512k
+
+UBIFS_OPTS = -m 4096 -e 516096 -c 4095
+UBINIZE_OPTS = -m 4096 -p 512KiB
+
+define Image/BuildKernel
+ cp $(KDIR)/linux-$(LINUX_VERSION)/arch/mips/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage.bin
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/xburst/image/ubinize.cfg b/target/linux/xburst/image/ubinize.cfg
new file mode 100644
index 0000000000..49d55b9840
--- /dev/null
+++ b/target/linux/xburst/image/ubinize.cfg
@@ -0,0 +1,14 @@
+[rootfs]
+# Volume mode (other option is static)
+mode=ubi
+# Source image
+image=root.ubifs
+# Volume ID in UBI image
+vol_id=0
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs
+# Autoresize volume at first mount
+vol_flags=autoresize
+