summaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/image
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-03-11 19:02:00 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-03-11 19:02:00 +0000
commit07b46f3a827812657c118e6b4beff4d0283a5057 (patch)
tree88e5552c90f6612d7a54af7ff3ed9457eea6cbfa /target/linux/xburst/image
parent07e59c7bc7f375f792ec9734be42fe4fa391a8bb (diff)
downloadmaster-31e0f0ae-07b46f3a827812657c118e6b4beff4d0283a5057.tar.gz
master-31e0f0ae-07b46f3a827812657c118e6b4beff4d0283a5057.tar.bz2
master-31e0f0ae-07b46f3a827812657c118e6b4beff4d0283a5057.zip
Fix image generation for qi_lb60 subtarget
SVN-Revision: 20152
Diffstat (limited to 'target/linux/xburst/image')
-rw-r--r--target/linux/xburst/image/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 0947db0549..199ba2b7d4 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=256k 512k
-ifneq ($(CONFIG_TARGET_QI_LB60),)
+ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
UBIFS_OPTS = -m 4096 -e 516096 -c 4095
UBINIZE_OPTS = -m 4096 -p 512KiB
else
@@ -17,16 +17,6 @@ UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
endif
-ifneq ($(CONFIG_XBURST_UBOOT),)
- define Build/Clean
- $(MAKE) -C u-boot clean
- endef
-
- define Build/Compile
- $(MAKE) -C u-boot compile
- endef
-endif
-
define Image/BuildKernel
cp $(KDIR)/linux-$(LINUX_VERSION)/arch/mips/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage.bin
endef