summaryrefslogtreecommitdiffstats
path: root/target/linux/x86_64/patches
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-07 12:23:35 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-07 12:23:35 +0000
commit7aaa9bc91c9e905f3b943e2b8a1cb3ce140fe9a5 (patch)
tree4dbb15c6e8f7142918e2ae8adc6b0efc39dca879 /target/linux/x86_64/patches
parent8603b30db51404dfde353d021bc0379290b9d331 (diff)
downloadmaster-31e0f0ae-7aaa9bc91c9e905f3b943e2b8a1cb3ce140fe9a5.tar.gz
master-31e0f0ae-7aaa9bc91c9e905f3b943e2b8a1cb3ce140fe9a5.tar.bz2
master-31e0f0ae-7aaa9bc91c9e905f3b943e2b8a1cb3ce140fe9a5.zip
add x86_64 target support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39208
Diffstat (limited to 'target/linux/x86_64/patches')
-rw-r--r--target/linux/x86_64/patches/011-tune_lzma_options.patch22
-rw-r--r--target/linux/x86_64/patches/012-export_erase_write.patch23
2 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/x86_64/patches/011-tune_lzma_options.patch b/target/linux/x86_64/patches/011-tune_lzma_options.patch
new file mode 100644
index 0000000000..1421f7c8fa
--- /dev/null
+++ b/target/linux/x86_64/patches/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -303,7 +303,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+
+ quiet_cmd_lzma = LZMA $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ (rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -23,7 +23,7 @@
+ #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ #define BOOT_HEAP_SIZE 0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */
+
diff --git a/target/linux/x86_64/patches/012-export_erase_write.patch b/target/linux/x86_64/patches/012-export_erase_write.patch
new file mode 100644
index 0000000000..d3ec5caf14
--- /dev/null
+++ b/target/linux/x86_64/patches/012-export_erase_write.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/mtdblock.c
++++ b/drivers/mtd/mtdblock.c
+@@ -62,7 +62,7 @@ static void erase_callback(struct erase_
+ wake_up(wait_q);
+ }
+
+-static int erase_write (struct mtd_info *mtd, unsigned long pos,
++int erase_write (struct mtd_info *mtd, unsigned long pos,
+ int len, const char *buf)
+ {
+ struct erase_info erase;
+--- a/include/linux/mtd/mtd.h
++++ b/include/linux/mtd/mtd.h
+@@ -409,6 +409,9 @@ extern void register_mtd_user (struct mt
+ extern int unregister_mtd_user (struct mtd_notifier *old);
+ void *mtd_kmalloc_up_to(const struct mtd_info *mtd, size_t *size);
+
++int erase_write (struct mtd_info *mtd, unsigned long pos,
++ int len, const char *buf);
++
+ void mtd_erase_callback(struct erase_info *instr);
+
+ static inline int mtd_is_bitflip(int err) {