summaryrefslogtreecommitdiffstats
path: root/target/linux/x86_64/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-07 12:23:35 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-07 12:23:35 +0000
commit7aaa9bc91c9e905f3b943e2b8a1cb3ce140fe9a5 (patch)
tree4dbb15c6e8f7142918e2ae8adc6b0efc39dca879 /target/linux/x86_64/Makefile
parent8603b30db51404dfde353d021bc0379290b9d331 (diff)
downloadmaster-31e0f0ae-7aaa9bc91c9e905f3b943e2b8a1cb3ce140fe9a5.tar.gz
master-31e0f0ae-7aaa9bc91c9e905f3b943e2b8a1cb3ce140fe9a5.tar.bz2
master-31e0f0ae-7aaa9bc91c9e905f3b943e2b8a1cb3ce140fe9a5.zip
add x86_64 target support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39208
Diffstat (limited to 'target/linux/x86_64/Makefile')
-rw-r--r--target/linux/x86_64/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/x86_64/Makefile b/target/linux/x86_64/Makefile
new file mode 100644
index 0000000000..09913f2689
--- /dev/null
+++ b/target/linux/x86_64/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=x86_64
+BOARD:=x86_64
+BOARDNAME:=x86_64
+FEATURES:=ext4 vdi vmdk targz
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+LINUX_VERSION:=3.10.24
+
+KERNELNAME:=bzImage
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-e1000
+
+$(eval $(call BuildTarget))