summaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-03 18:39:08 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-03 18:39:11 +0200
commitd5ee23ee275fcd6550b0051de59706cc928cdac8 (patch)
tree4eb56932688c7e016f5b6c3440e0fc8356bee958 /target/linux/x86
parentf226d5879e9f38bbc0aabbaeca94622e2a4b0cee (diff)
downloadmaster-31e0f0ae-d5ee23ee275fcd6550b0051de59706cc928cdac8.tar.gz
master-31e0f0ae-d5ee23ee275fcd6550b0051de59706cc928cdac8.tar.bz2
master-31e0f0ae-d5ee23ee275fcd6550b0051de59706cc928cdac8.zip
x86: stop relying on hexdump for image build signature
Use perl to generate random number instead. See https://github.com/freifunk-gluon/gluon/issues/811 Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index d33d1b4fa3..93b7fca2b7 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -40,7 +40,7 @@ ifneq ($(GRUB_TERMINALS),)
GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
endif
-SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%08x"')
+SIGNATURE:=$(shell perl -e 'printf("%08x", rand(0xFFFFFFFF))')
ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)