summaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-12 17:39:04 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-12 17:39:04 +0200
commit2e5f84fc10a5feeb1bb6a9805904b93ff6dc24bb (patch)
treef98c507cdd913f5966956402fa3b99c3a0107f7b /target/linux/x86
parentca12fd431d8dc03e182e3e34a18e1efe65b0111c (diff)
downloadmaster-31e0f0ae-2e5f84fc10a5feeb1bb6a9805904b93ff6dc24bb.tar.gz
master-31e0f0ae-2e5f84fc10a5feeb1bb6a9805904b93ff6dc24bb.tar.bz2
master-31e0f0ae-2e5f84fc10a5feeb1bb6a9805904b93ff6dc24bb.zip
x86: remove legacy script/makefile code for rdc devices
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/image/Makefile24
-rwxr-xr-xtarget/linux/x86/image/mkimg_bifferboard.py50
-rwxr-xr-xtarget/linux/x86/image/mkimg_sitecom.pl11
3 files changed, 0 insertions, 85 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 64a5e058cb..98c2150e52 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -181,30 +181,6 @@ define Image/BuildKernel
endif
endef
-define Image/Build/Profile/ar525w
- cp $(KDIR)/bzImage $(KDIR)/bzImage.tmp
- $(SCRIPT_DIR)/pad_image $(1) $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) 32
- $(STAGING_DIR_HOST)/bin/airlink -b 1 $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) \
- $(BIN_DIR)/$(IMG_PREFIX)-$(1)-ar525w.img
- $(STAGING_DIR_HOST)/bin/airlink -e -b 1 $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) \
- $(BIN_DIR)/$(IMG_PREFIX)-$(1)-ar525w-web.img
-endef
-
-define Image/Build/Profile/sitecom
- cp $(KDIR)/bzImage $(KDIR)/bzImage.tmp
- #32k config data + 20 bytes header + 2 bytes checksum after kernel image
- $(SCRIPT_DIR)/pad_image $(1) $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) 32790
- $(TOPDIR)/target/linux/rdc/image/mkimg_sitecom.pl $(KDIR)/bzImage.tmp > $(KDIR)/tmp.img
- cat $(KDIR)/root.$(1) >> $(KDIR)/tmp.img
- cp $(KDIR)/tmp.img $(BIN_DIR)/$(IMG_PREFIX)-$(1)-sitecom.img
- rm $(KDIR)/tmp.img $(KDIR)/bzImage.tmp
-endef
-
-define Image/Build/Profile/bifferboard
- $(TOPDIR)/target/linux/rdc/image/mkimg_bifferboard.py $(KDIR)/bzImage $(KDIR)/root.$(1) \
- $(BIN_DIR)/$(IMG_PREFIX)-$(1)-bifferboard.img
-endef
-
define Image/Prepare
$(call Image/Prepare/grub2)
endef
diff --git a/target/linux/x86/image/mkimg_bifferboard.py b/target/linux/x86/image/mkimg_bifferboard.py
deleted file mode 100755
index 5444abebd1..0000000000
--- a/target/linux/x86/image/mkimg_bifferboard.py
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/usr/bin/env python
-
-"""
- Create firmware for 4/8MB Bifferboards, suitable for uploading using
- either bb_upload8.py or bb_eth_upload8.py
-"""
-
-import struct, sys
-
-# Increase the kmax value if the script gives errors about the kernel being
-# too large. You need to set the Biffboot kmax value to the same value you
-# use here.
-kmax = 0x10
-
-# No need to change this for 4MB devices, it's only used to tell you if
-# the firmware is too large!
-flash_size = 0x800000
-
-# This is always the same, for 1MB, 4MB and 8MB devices
-config_extent = 0x6000
-
-kernel_extent = kmax * 0x10000
-
-if __name__ == "__main__":
-
- if len(sys.argv) != 4:
- print "usage: mkimg_bifferboard.py <kernel> <rootfs> <output file>"
- sys.exit(-1)
-
- bzimage = sys.argv[1]
- rootfs = sys.argv[2]
- target = sys.argv[3]
-
- # Kernel first
- fw = file(bzimage).read()
- if len(fw) > (kernel_extent - config_extent):
- raise IOError("Kernel too large")
-
- # Pad up to end of kernel partition
- while len(fw) < (kernel_extent - config_extent):
- fw += "\xff"
-
- fw += file(rootfs).read()
-
- # Check length of total
- if len(fw) > (flash_size - 0x10000 - config_extent):
- raise IOError("Rootfs too large")
-
- file(target,"wb").write(fw)
- print "Firmware written to '%s'" % target
diff --git a/target/linux/x86/image/mkimg_sitecom.pl b/target/linux/x86/image/mkimg_sitecom.pl
deleted file mode 100755
index cfd5e652f0..0000000000
--- a/target/linux/x86/image/mkimg_sitecom.pl
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/usr/bin/perl
-
-open (bzimg, @ARGV[0]);
-while (<bzimg>) { $i .= $_; }
-$i .= pack "v", -(unpack "%v*", $i);
-print "CSYS";
-print pack("V", length($i));
-print pack("V", 0);
-print "WRRM";
-print pack("V", length($i));
-print $i;