summaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-16 07:12:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-16 07:12:31 +0000
commitf2f8f6974b52251580608923557b5355ea3aebe3 (patch)
treec7ce8dd2b8431f8c31dfae17705b31ba6429ae05 /target/linux/x86
parent9e0759ea2653475f4e891c412fa503e9a9b08478 (diff)
downloadmaster-31e0f0ae-f2f8f6974b52251580608923557b5355ea3aebe3.tar.gz
master-31e0f0ae-f2f8f6974b52251580608923557b5355ea3aebe3.tar.bz2
master-31e0f0ae-f2f8f6974b52251580608923557b5355ea3aebe3.zip
x86: refresh kernel patches
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44810
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/patches-3.18/009-rdc321x_select_embedded.patch2
-rw-r--r--target/linux/x86/patches-3.18/010-rdc_cpu_ident.patch6
-rw-r--r--target/linux/x86/patches-3.18/011-tune_lzma_options.patch2
-rw-r--r--target/linux/x86/patches-3.18/012-export_erase_write.patch2
-rw-r--r--target/linux/x86/patches-3.18/120-panic_on_unrecovered_nmi.patch2
5 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/x86/patches-3.18/009-rdc321x_select_embedded.patch b/target/linux/x86/patches-3.18/009-rdc321x_select_embedded.patch
index 50f817cb28..e1599e4f54 100644
--- a/target/linux/x86/patches-3.18/009-rdc321x_select_embedded.patch
+++ b/target/linux/x86/patches-3.18/009-rdc321x_select_embedded.patch
@@ -1,6 +1,6 @@
--- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig
-@@ -480,6 +480,8 @@ config X86_RDC321X
+@@ -531,6 +531,8 @@ config X86_RDC321X
depends on X86_EXTENDED_PLATFORM
select M486
select X86_REBOOTFIXUPS
diff --git a/target/linux/x86/patches-3.18/010-rdc_cpu_ident.patch b/target/linux/x86/patches-3.18/010-rdc_cpu_ident.patch
index 043c3a31f5..64d38c1b7a 100644
--- a/target/linux/x86/patches-3.18/010-rdc_cpu_ident.patch
+++ b/target/linux/x86/patches-3.18/010-rdc_cpu_ident.patch
@@ -72,7 +72,7 @@
+
--- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig
-@@ -478,6 +478,7 @@ config X86_RDC321X
+@@ -529,6 +529,7 @@ config X86_RDC321X
bool "RDC R-321x SoC"
depends on X86_32
depends on X86_EXTENDED_PLATFORM
@@ -82,7 +82,7 @@
select EMBEDDED
--- a/arch/x86/include/asm/processor.h
+++ b/arch/x86/include/asm/processor.h
-@@ -137,7 +137,8 @@ struct cpuinfo_x86 {
+@@ -136,7 +136,8 @@ struct cpuinfo_x86 {
#define X86_VENDOR_CENTAUR 5
#define X86_VENDOR_TRANSMETA 7
#define X86_VENDOR_NSC 8
@@ -94,7 +94,7 @@
--- a/arch/x86/kernel/cpu/Makefile
+++ b/arch/x86/kernel/cpu/Makefile
-@@ -26,6 +26,7 @@ obj-$(CONFIG_CPU_SUP_CYRIX_32) += cyrix
+@@ -29,6 +29,7 @@ obj-$(CONFIG_CPU_SUP_CYRIX_32) += cyrix
obj-$(CONFIG_CPU_SUP_CENTAUR) += centaur.o
obj-$(CONFIG_CPU_SUP_TRANSMETA_32) += transmeta.o
obj-$(CONFIG_CPU_SUP_UMC_32) += umc.o
diff --git a/target/linux/x86/patches-3.18/011-tune_lzma_options.patch b/target/linux/x86/patches-3.18/011-tune_lzma_options.patch
index 168c3dd731..4bb7b7bf45 100644
--- a/target/linux/x86/patches-3.18/011-tune_lzma_options.patch
+++ b/target/linux/x86/patches-3.18/011-tune_lzma_options.patch
@@ -1,6 +1,6 @@
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
-@@ -304,7 +304,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+@@ -325,7 +325,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
quiet_cmd_lzma = LZMA $@
cmd_lzma = (cat $(filter-out FORCE,$^) | \
diff --git a/target/linux/x86/patches-3.18/012-export_erase_write.patch b/target/linux/x86/patches-3.18/012-export_erase_write.patch
index 9927384cb8..a98525ee50 100644
--- a/target/linux/x86/patches-3.18/012-export_erase_write.patch
+++ b/target/linux/x86/patches-3.18/012-export_erase_write.patch
@@ -11,7 +11,7 @@
struct erase_info erase;
--- a/include/linux/mtd/mtd.h
+++ b/include/linux/mtd/mtd.h
-@@ -414,6 +414,9 @@ extern void register_mtd_user (struct mt
+@@ -416,6 +416,9 @@ extern void register_mtd_user (struct mt
extern int unregister_mtd_user (struct mtd_notifier *old);
void *mtd_kmalloc_up_to(const struct mtd_info *mtd, size_t *size);
diff --git a/target/linux/x86/patches-3.18/120-panic_on_unrecovered_nmi.patch b/target/linux/x86/patches-3.18/120-panic_on_unrecovered_nmi.patch
index 641bb387ac..0432686cf1 100644
--- a/target/linux/x86/patches-3.18/120-panic_on_unrecovered_nmi.patch
+++ b/target/linux/x86/patches-3.18/120-panic_on_unrecovered_nmi.patch
@@ -1,6 +1,6 @@
--- a/drivers/mfd/rdc321x-southbridge.c
+++ b/drivers/mfd/rdc321x-southbridge.c
-@@ -86,6 +86,8 @@ static int rdc321x_sb_probe(struct pci_d
+@@ -85,6 +85,8 @@ static int rdc321x_sb_probe(struct pci_d
rdc321x_gpio_pdata.sb_pdev = pdev;
rdc321x_wdt_pdata.sb_pdev = pdev;