summaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-11-28 18:04:36 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-11-28 18:04:36 +0000
commite9cf2c505a7b6887076756f406cadd988cb656c1 (patch)
tree6ada59a14bf474435874ba73bb3fdd2c51cecb6a /target/linux/x86
parentb2ec8ffd5c8e4bc79ac1e3e9f314a96bb8ce17c1 (diff)
downloadmaster-31e0f0ae-e9cf2c505a7b6887076756f406cadd988cb656c1.tar.gz
master-31e0f0ae-e9cf2c505a7b6887076756f406cadd988cb656c1.tar.bz2
master-31e0f0ae-e9cf2c505a7b6887076756f406cadd988cb656c1.zip
split Soekris profile into 45xx and 48xx, add kernel package for required watchdog driver on 45xx
SVN-Revision: 13411
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/generic/profiles/Soekris45xx.mk16
-rw-r--r--target/linux/x86/generic/profiles/Soekris48xx.mk (renamed from target/linux/x86/generic/profiles/Soekris.mk)10
2 files changed, 21 insertions, 5 deletions
diff --git a/target/linux/x86/generic/profiles/Soekris45xx.mk b/target/linux/x86/generic/profiles/Soekris45xx.mk
new file mode 100644
index 0000000000..a3255178be
--- /dev/null
+++ b/target/linux/x86/generic/profiles/Soekris45xx.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Soekris45xx
+ NAME:=Soekris Net45xx
+ PACKAGES:=kmod-natsemi kmod-leds-net48xx kmod-sc520-wdt
+endef
+
+define Profile/Soekris45xx/Description
+ Package set compatible with the Soekris Net45xx. Net4511 and 4521 need PCMCIA Cardbus support. Please add manually.
+endef
+$(eval $(call Profile,Soekris45xx))
diff --git a/target/linux/x86/generic/profiles/Soekris.mk b/target/linux/x86/generic/profiles/Soekris48xx.mk
index 8cce126039..e4d17fe520 100644
--- a/target/linux/x86/generic/profiles/Soekris.mk
+++ b/target/linux/x86/generic/profiles/Soekris48xx.mk
@@ -1,16 +1,16 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-define Profile/Soekris
- NAME:=Soekris Net4801
+define Profile/Soekris48xx
+ NAME:=Soekris Net48xx
PACKAGES:=kmod-i2c-scx200 kmod-natsemi kmod-leds-net48xx kmod-scx200-gpio kmod-scx200-wdt kmod-hwmon-pc87360
endef
-define Profile/Soekris/Description
+define Profile/Soekris48xx/Description
Package set compatible with the Soekris Net4801. Contains I2C/LEDS/GPIO/Sensors support
endef
-$(eval $(call Profile,Soekris))
+$(eval $(call Profile,Soekris48xx))