summaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-01-10 23:12:21 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-01-10 23:12:21 +0000
commite0440fefb667c6a71e8b9dc64d1c12ea4d627351 (patch)
tree9dc6b936804c29ff3adf8845825845be48797819 /target/linux/x86
parenta455323221d17b487d20df3a3fef627c0159a0f7 (diff)
downloadmaster-31e0f0ae-e0440fefb667c6a71e8b9dc64d1c12ea4d627351.tar.gz
master-31e0f0ae-e0440fefb667c6a71e8b9dc64d1c12ea4d627351.tar.bz2
master-31e0f0ae-e0440fefb667c6a71e8b9dc64d1c12ea4d627351.zip
Use wildcards to copy grub stage files, will cover both i386-pc and i386-openwrt directory names
SVN-Revision: 13963
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index a740b0b63c..4d76639923 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -49,9 +49,9 @@ ifneq ($(HOST_OS),Darwin)
define Image/Prepare/grub
# for the image builder
$(CP) \
- $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/stage1 \
- $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/stage2 \
- $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/e2fs_stage1_5 \
+ $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage1 \
+ $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage2 \
+ $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/e2fs_stage1_5 \
$(KDIR)/
endef
else