summaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-28 11:37:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-28 11:37:08 +0000
commit742700719303feedac8f98fd801c0ef769c52ead (patch)
tree5b753c4c0c90fc3a0e6dbe30733bddbc55d0c5d4 /target/linux/x86
parent518d2b90e644b041259ab796aab0e2469789713d (diff)
downloadmaster-31e0f0ae-742700719303feedac8f98fd801c0ef769c52ead.tar.gz
master-31e0f0ae-742700719303feedac8f98fd801c0ef769c52ead.tar.bz2
master-31e0f0ae-742700719303feedac8f98fd801c0ef769c52ead.zip
x86: remove the olpc subtarget, it has been unmaintained for a long time
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45083
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/Makefile2
-rw-r--r--target/linux/x86/image/Config.in6
-rw-r--r--target/linux/x86/image/Makefile34
-rwxr-xr-xtarget/linux/x86/image/gen_image_olpc.sh35
-rw-r--r--target/linux/x86/image/olpc.fth5
-rw-r--r--target/linux/x86/olpc/base-files/etc/X11/xorg.conf71
-rw-r--r--target/linux/x86/olpc/base-files/etc/config/network16
-rw-r--r--target/linux/x86/olpc/base-files/lib/preinit/15_essential_fs_x867
-rw-r--r--target/linux/x86/olpc/base-files/lib/upgrade/platform.sh27
-rw-r--r--target/linux/x86/olpc/config-default120
-rw-r--r--target/linux/x86/olpc/target.mk3
11 files changed, 1 insertions, 325 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index b5164d81ec..d5545fbc79 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -10,7 +10,7 @@ ARCH:=i386
BOARD:=x86
BOARDNAME:=x86
FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
-SUBTARGETS=generic olpc xen_domu ep80579 geode kvm_guest rdc
+SUBTARGETS=generic xen_domu ep80579 geode kvm_guest rdc
KERNEL_PATCHVER:=3.18
diff --git a/target/linux/x86/image/Config.in b/target/linux/x86/image/Config.in
index d2ef9fb7fa..f232c647a5 100644
--- a/target/linux/x86/image/Config.in
+++ b/target/linux/x86/image/Config.in
@@ -12,9 +12,3 @@ config X86_ETHERBOOT_BOOTOPTS
default "ip=dhcp root=/dev/nfs nfsroot=192.168.0.1:/srv/dbe61"
help
Kernel arguments to pass to the kernel eg. NFS root location etc.
-
-config OLPC_BOOTSCRIPT_IMAGES
- bool "Build images with bootscript"
- depends on TARGET_x86_olpc
- depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
- default TARGET_x86_olpc
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 85460206c0..ffda5c1578 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -100,38 +100,6 @@ endif
ROOTDELAY=10
-ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
-
- define Image/cmdline/ext4
- root=$(ROOTPART) rootfstype=ext4 rootwait
- endef
-
- define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
- endef
-
- define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
- endef
-
- define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootdelay=$(ROOTDELAY)
- endef
-
- define Image/Build/bootscript
- # left here because the image builder doesnt need these
- $(INSTALL_DIR) $(KDIR)/root.bootscript/boot
- $(CP) $(KDIR)/bzImage $(KDIR)/root.bootscript/boot/vmlinuz
- sed -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
- ./olpc.fth > $(KDIR)/root.bootscript/boot/olpc.fth
- PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_olpc.sh \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
- $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.bootscript \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
- endef
-
-endif
-
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef
@@ -239,7 +207,6 @@ endef
define Image/Prepare
$(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
- $(call Image/Prepare/bootscript)
$(call Image/Prepare/grub2)
endef
@@ -249,7 +216,6 @@ endef
define Image/Build
$(call Image/Build/$(1))
- $(call Image/Build/bootscript,$(1))
ifneq ($(1),iso)
$(call Image/Build/grub2,$(1))
$(call Image/Build/vdi,$(1))
diff --git a/target/linux/x86/image/gen_image_olpc.sh b/target/linux/x86/image/gen_image_olpc.sh
deleted file mode 100755
index 82bc4ed957..0000000000
--- a/target/linux/x86/image/gen_image_olpc.sh
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/usr/bin/env bash
-# Copyright (C) 2006-2010 OpenWrt.org
-set -x
-[ $# == 5 ] || {
- echo "SYNTAX: $0 <file> <kernel size> <kernel directory> <rootfs size> <rootfs image>"
- exit 1
-}
-
-OUTPUT="$1"
-KERNELSIZE="$2"
-KERNELDIR="$3"
-ROOTFSSIZE="$4"
-ROOTFSIMAGE="$5"
-
-rm -f "$OUTPUT"
-
-head=16
-sect=63
-cyl=$(( ($KERNELSIZE + $ROOTFSSIZE) * 1024 * 1024 / ($head * $sect * 512)))
-
-# create partition table
-set `ptgen -o "$OUTPUT" -h $head -s $sect -p ${KERNELSIZE}m -p ${ROOTFSSIZE}m`
-
-KERNELOFFSET="$(($1 / 512))"
-KERNELSIZE="$(($2 / 512))"
-ROOTFSOFFSET="$(($3 / 512))"
-ROOTFSSIZE="$(($4 / 512))"
-
-BLOCKS="$((($KERNELSIZE / 2) - 1))"
-
-genext2fs -d "$KERNELDIR" -b "$BLOCKS" "$OUTPUT.kernel"
-dd if="$OUTPUT.kernel" of="$OUTPUT" bs=512 seek="$KERNELOFFSET" conv=notrunc
-[ -n "$PADDING" ] && dd if=/dev/zero of="$OUTPUT" bs=512 seek="$ROOTFSOFFSET" conv=notrunc count="$ROOTFSSIZE"
-dd if="$ROOTFSIMAGE" of="$OUTPUT" bs=512 seek="$ROOTFSOFFSET" conv=notrunc
-rm -f "$OUTPUT.kernel"
diff --git a/target/linux/x86/image/olpc.fth b/target/linux/x86/image/olpc.fth
deleted file mode 100644
index 5914be6606..0000000000
--- a/target/linux/x86/image/olpc.fth
+++ /dev/null
@@ -1,5 +0,0 @@
-\ Boot script
-" u:\boot\vmlinuz" to boot-device
-" @CMDLINE@ noinitrd console=ttyS0,115200 console=tty0" to boot-file
-unfreeze
-boot
diff --git a/target/linux/x86/olpc/base-files/etc/X11/xorg.conf b/target/linux/x86/olpc/base-files/etc/X11/xorg.conf
deleted file mode 100644
index d98a8f87a5..0000000000
--- a/target/linux/x86/olpc/base-files/etc/X11/xorg.conf
+++ /dev/null
@@ -1,71 +0,0 @@
-# xorg configuration
-
-Section "ServerLayout"
- Identifier "Default Layout"
- Screen 0 "Screen0" 0 0
- InputDevice "Mouse0" "CorePointer"
- InputDevice "Keyboard0" "CoreKeyboard"
-EndSection
-
-Section "Files"
- FontPath "/usr/lib/X11/fonts/misc"
-EndSection
-
-Section "Module"
- Load "dbe"
- Load "extmod"
- Load "fbdevhw"
-# Load "glx"
- Load "record"
- Load "freetype"
- Load "type1"
-EndSection
-
-Section "InputDevice"
- Identifier "Keyboard0"
- Driver "keyboard"
- Option "XkbModel" "pc105"
- Option "XkbLayout" "us"
-EndSection
-
-Section "InputDevice"
- Identifier "Mouse0"
- Driver "mouse"
- Option "Protocol" "PS/2"
- Option "Device" "/dev/psaux"
- Option "ZAxisMapping" "4 5"
- Option "Emulate3Buttons" "yes"
-EndSection
-
-Section "Monitor"
- Identifier "Monitor0"
- VendorName "Monitor Vendor"
- ModelName "OWRT"
- Option "dpms"
-EndSection
-
-Section "Device"
- Identifier "FBDev"
- Driver "fbdev"
- #Option "shadowfb" "off"
- VideoRam 4096
-EndSection
-
-Section "Screen"
- Identifier "Screen0"
- Device "FBDev"
- Monitor "Monitor0"
- DefaultDepth 16
-
- SubSection "Display"
- Depth 16
- Modes "1200x900-75"
- EndSubsection
-
-EndSection
-
-Section "DRI"
- Group 0
- Mode 0666
-EndSection
-
diff --git a/target/linux/x86/olpc/base-files/etc/config/network b/target/linux/x86/olpc/base-files/etc/config/network
deleted file mode 100644
index dc0bee1ee7..0000000000
--- a/target/linux/x86/olpc/base-files/etc/config/network
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright (C) 2006 OpenWrt.org
-
-config interface loopback
- option ifname lo
- option proto static
- option ipaddr 127.0.0.1
- option netmask 255.0.0.0
-
-config interface wlan
- option ifname eth0
- option proto dhcp
-
-config interface wlan6
- option ifname @wlan
- option proto dhcpv6
- option reqprefix no
diff --git a/target/linux/x86/olpc/base-files/lib/preinit/15_essential_fs_x86 b/target/linux/x86/olpc/base-files/lib/preinit/15_essential_fs_x86
deleted file mode 100644
index e4a380fd5f..0000000000
--- a/target/linux/x86/olpc/base-files/lib/preinit/15_essential_fs_x86
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2006-2010 OpenWrt.org
-# Copyright (C) 2010 Vertical Communications
-
-do_mount_procfs() {
- mount -o noatime -t proc none /proc
-}
diff --git a/target/linux/x86/olpc/base-files/lib/upgrade/platform.sh b/target/linux/x86/olpc/base-files/lib/upgrade/platform.sh
deleted file mode 100644
index c90a4ce1c4..0000000000
--- a/target/linux/x86/olpc/base-files/lib/upgrade/platform.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-platform_check_image() {
- [ "$#" -gt 1 ] && return 1
-
- case "$(get_magic_word "$1")" in
- 48eb) return 0;;
- *)
- echo "Invalid image type"
- return 1
- ;;
- esac
-}
-
-platform_do_upgrade() {
- get_image "$1" > /dev/hda
- sync
-}
-
-x86_prepare_ext2() {
- # if we're running from ext2, we need to make sure that we have a mtd
- # partition that points to the active rootfs partition.
- # however this only matters if we actually need to preserve the config files
- [ "$SAVE_CONFIG" -eq 1 ] && return 0
- grep rootfs /proc/mtd >/dev/null || {
- echo /dev/hda2,65536,rootfs > /sys/module/block2mtd/parameters/block2mtd
- }
-}
-append sysupgrade_pre_upgrade x86_prepare_ext2
diff --git a/target/linux/x86/olpc/config-default b/target/linux/x86/olpc/config-default
deleted file mode 100644
index 90f0302d55..0000000000
--- a/target/linux/x86/olpc/config-default
+++ /dev/null
@@ -1,120 +0,0 @@
-# CONFIG_APM is not set
-CONFIG_BACKLIGHT_CLASS_DEVICE=y
-CONFIG_BACKLIGHT_GENERIC=y
-CONFIG_BACKLIGHT_LCD_SUPPORT=y
-# CONFIG_BACKLIGHT_SAHARA is not set
-CONFIG_BATTERY_OLPC=y
-CONFIG_BLK_DEV_SR=y
-CONFIG_BLK_DEV_SR_VENDOR=y
-# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
-CONFIG_BOOTPARAM_HUNG_TASK_PANIC_VALUE=0
-CONFIG_CHR_DEV_SG=y
-# CONFIG_CPU_FREQ_STAT_DETAILS is not set
-CONFIG_CPU_IDLE_GOV_MENU=y
-CONFIG_DECOMPRESS_LZO=y
-CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120
-CONFIG_DETECT_HUNG_TASK=y
-# CONFIG_EMBEDDED is not set
-CONFIG_FB=y
-CONFIG_FB_CFB_COPYAREA=y
-CONFIG_FB_CFB_FILLRECT=y
-CONFIG_FB_CFB_IMAGEBLIT=y
-CONFIG_FB_GEODE=y
-# CONFIG_FB_GEODE_GX is not set
-# CONFIG_FB_GEODE_GX1 is not set
-CONFIG_FB_GEODE_LX=y
-# CONFIG_FB_OLPC_DCON is not set
-# CONFIG_FB_VESA is not set
-CONFIG_FREEZER=y
-CONFIG_GPIOLIB=y
-# CONFIG_GPIO_SODAVILLE is not set
-CONFIG_HIBERNATE_CALLBACKS=y
-CONFIG_HIBERNATION=y
-# CONFIG_HIGHMEM64G is not set
-CONFIG_IRQCHIP=y
-CONFIG_IRQ_DOMAIN=y
-# CONFIG_KEXEC_JUMP is not set
-CONFIG_LCD_CLASS_DEVICE=y
-# CONFIG_LCD_PLATFORM is not set
-CONFIG_LZO_COMPRESS=y
-CONFIG_LZO_DECOMPRESS=y
-# CONFIG_M486 is not set
-# CONFIG_MATH_EMULATION is not set
-CONFIG_MGEODE_LX=y
-CONFIG_MMC=y
-CONFIG_MMC_BLOCK=y
-CONFIG_MMC_SDHCI=y
-# CONFIG_MMC_SDHCI_PCI is not set
-# CONFIG_MMC_SDHCI_PLTFM is not set
-# CONFIG_MMC_TIFM_SD is not set
-# CONFIG_MMC_WBSD is not set
-CONFIG_MTD_CMDLINE_PARTS=y
-CONFIG_MTD_OF_PARTS=y
-# CONFIG_MTRR is not set
-# CONFIG_NETWORK_FILESYSTEMS is not set
-CONFIG_NLS=y
-CONFIG_NO_HZ=y
-CONFIG_OF=y
-CONFIG_OF_ADDRESS=y
-CONFIG_OF_DEVICE=y
-CONFIG_OF_GPIO=y
-CONFIG_OF_IRQ=y
-CONFIG_OF_MTD=y
-CONFIG_OF_NET=y
-CONFIG_OF_PCI=y
-CONFIG_OF_PCI_IRQ=y
-CONFIG_OF_PROMTREE=y
-CONFIG_OLPC=y
-CONFIG_OPROFILE=y
-# CONFIG_OPROFILE_EVENT_MULTIPLEX is not set
-# CONFIG_PARTITION_ADVANCED is not set
-# CONFIG_PCI_GOANY is not set
-CONFIG_PCI_GOOLPC=y
-CONFIG_PCI_OLPC=y
-CONFIG_PM=y
-# CONFIG_PM_ADVANCED_DEBUG is not set
-CONFIG_PM_DEBUG=y
-CONFIG_PM_SLEEP=y
-CONFIG_PM_SLEEP_DEBUG=y
-CONFIG_PM_STD_PARTITION=""
-# CONFIG_PM_TEST_SUSPEND is not set
-# CONFIG_PM_TRACE_RTC is not set
-# CONFIG_PREEMPT_NONE is not set
-CONFIG_PREEMPT_VOLUNTARY=y
-CONFIG_PROFILING=y
-CONFIG_RD_LZO=y
-CONFIG_RELAY=y
-CONFIG_RING_BUFFER=y
-CONFIG_RING_BUFFER_ALLOW_SWAP=y
-CONFIG_SCHEDSTATS=y
-CONFIG_SCHED_DEBUG=y
-# CONFIG_SCx200 is not set
-# CONFIG_SERIO_APBPS2 is not set
-CONFIG_SUSPEND=y
-CONFIG_SUSPEND_FREEZER=y
-CONFIG_TIMER_STATS=y
-CONFIG_TRACE_CLOCK=y
-CONFIG_USB=y
-CONFIG_USB_COMMON=y
-CONFIG_USB_EHCI_HCD=y
-# CONFIG_USB_EHCI_HCD_PLATFORM is not set
-CONFIG_USB_EHCI_PCI=y
-# CONFIG_USB_OHCI_BIG_ENDIAN_DESC is not set
-# CONFIG_USB_OHCI_BIG_ENDIAN_MMIO is not set
-CONFIG_USB_OHCI_HCD=y
-# CONFIG_USB_OHCI_HCD_PLATFORM is not set
-CONFIG_USB_STORAGE=y
-CONFIG_USB_UHCI_HCD=y
-CONFIG_VGA_ARB=y
-CONFIG_VGA_ARB_MAX_GPUS=16
-# CONFIG_WATCHDOG is not set
-CONFIG_X86_CMOV=y
-CONFIG_X86_DEBUGCTLMSR=y
-CONFIG_X86_EXTENDED_PLATFORM=y
-# CONFIG_X86_MCE is not set
-# CONFIG_X86_RDC321X is not set
-# CONFIG_X86_REROUTE_FOR_BROKEN_BOOT_IRQS is not set
-CONFIG_X86_TSC=y
-CONFIG_X86_USE_3DNOW=y
-CONFIG_X86_USE_PPRO_CHECKSUM=y
-# CONFIG_X86_WANT_INTEL_MID is not set
diff --git a/target/linux/x86/olpc/target.mk b/target/linux/x86/olpc/target.mk
deleted file mode 100644
index 7a56b7ccd2..0000000000
--- a/target/linux/x86/olpc/target.mk
+++ /dev/null
@@ -1,3 +0,0 @@
-BOARDNAME:=OLPC XO-1
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci kmod-libertas
-FEATURES += broken