summaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-14 08:38:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-14 08:38:35 +0000
commit578aa97f8c160ec9cc31966285ca24809bbb134f (patch)
tree9cad6b2a2537b7f3ee5091dc8d6a69ef0eb7825d /target/linux/x86
parent5011d85ee8ab6ce775bc4681766dc204198b73a5 (diff)
downloadmaster-31e0f0ae-578aa97f8c160ec9cc31966285ca24809bbb134f.tar.gz
master-31e0f0ae-578aa97f8c160ec9cc31966285ca24809bbb134f.tar.bz2
master-31e0f0ae-578aa97f8c160ec9cc31966285ca24809bbb134f.zip
x86: disable rts/cts for serial console in grub - fixes net48xx boot issues
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44753
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 59837180f1..9e40803aa7 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -32,7 +32,7 @@ GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
ifneq ($(GRUB_SERIAL),)
GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8
- GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
+ GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=off
GRUB_TERMINALS += serial
endif