summaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2007-11-28 04:07:24 +0000
committerTravis Kemen <thepeople@openwrt.org>2007-11-28 04:07:24 +0000
commit38101a0cdc903b6f07bea96bea1fa8853ef0a787 (patch)
tree6c97976c0c528a12a29e757823df3a1a4e639ab5 /target/linux/x86
parentbe9bf2bf4093555b5ea30a4e6c4f19b761deeab2 (diff)
downloadmaster-31e0f0ae-38101a0cdc903b6f07bea96bea1fa8853ef0a787.tar.gz
master-31e0f0ae-38101a0cdc903b6f07bea96bea1fa8853ef0a787.tar.bz2
master-31e0f0ae-38101a0cdc903b6f07bea96bea1fa8853ef0a787.zip
add support for the PCEngines Alix
SVN-Revision: 9611
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/config-2.6.232
-rw-r--r--target/linux/x86/generic/profiles/Alix.mk16
2 files changed, 17 insertions, 1 deletions
diff --git a/target/linux/x86/config-2.6.23 b/target/linux/x86/config-2.6.23
index d04514b161..c12a2f95cf 100644
--- a/target/linux/x86/config-2.6.23
+++ b/target/linux/x86/config-2.6.23
@@ -349,7 +349,7 @@ CONFIG_USB_UHCI_HCD=m
# CONFIG_VGASTATE is not set
CONFIG_VGA_CONSOLE=y
CONFIG_VIA_RHINE=m
-# CONFIG_VIA_RHINE_MMIO is not set
+CONFIG_VIA_RHINE_MMIO=y
CONFIG_VIA_RHINE_NAPI=y
# CONFIG_VIDEO_SELECT is not set
# CONFIG_VIRTUALIZATION is not set
diff --git a/target/linux/x86/generic/profiles/Alix.mk b/target/linux/x86/generic/profiles/Alix.mk
new file mode 100644
index 0000000000..24f5bf1306
--- /dev/null
+++ b/target/linux/x86/generic/profiles/Alix.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Alix
+ NAME:=PCEngines Alix
+ PACKAGES:=kmod-via-rhine
+endef
+
+define Profile/Alix/Description
+ Package set compatible with the PCEngines Alix. Contains VIA Rhine III VT6105M support
+endef
+$(eval $(call Profile,Alix))