summaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-08 20:39:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-08 20:39:24 +0000
commit23fbd97649b4ce98716393815892a05892739904 (patch)
treee7b4f223810c623c95ea8aecd6fbefdf76eced4f /target/linux/x86
parent7f75961e381540aa0434a12732908475de946cdf (diff)
downloadmaster-31e0f0ae-23fbd97649b4ce98716393815892a05892739904.tar.gz
master-31e0f0ae-23fbd97649b4ce98716393815892a05892739904.tar.bz2
master-31e0f0ae-23fbd97649b4ce98716393815892a05892739904.zip
x86: add generic profiles to x86_64, kvm_guest and xen_domu
The imagebuilder requires a profile for every subtarget to work. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 47421
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/64/profiles/000-Generic.mk15
-rw-r--r--target/linux/x86/kvm_guest/profiles/000-Generic.mk15
-rw-r--r--target/linux/x86/xen_domu/profiles/000-Generic.mk15
3 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/x86/64/profiles/000-Generic.mk b/target/linux/x86/64/profiles/000-Generic.mk
new file mode 100644
index 0000000000..ccd125afa2
--- /dev/null
+++ b/target/linux/x86/64/profiles/000-Generic.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/kvm_guest/profiles/000-Generic.mk b/target/linux/x86/kvm_guest/profiles/000-Generic.mk
new file mode 100644
index 0000000000..ccd125afa2
--- /dev/null
+++ b/target/linux/x86/kvm_guest/profiles/000-Generic.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/xen_domu/profiles/000-Generic.mk b/target/linux/x86/xen_domu/profiles/000-Generic.mk
new file mode 100644
index 0000000000..ccd125afa2
--- /dev/null
+++ b/target/linux/x86/xen_domu/profiles/000-Generic.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))