summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-4.4
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-12 10:04:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-12 10:04:55 +0000
commit2172d7dbbfe453ea81ebf0b4e62d8101a7d5d1f0 (patch)
treee5c52caa9f0fd6ead2340a33bb1c8836916e9cf1 /target/linux/x86/patches-4.4
parent9e7a66d1951ca57a081ae97e02085127a00d09be (diff)
downloadmaster-31e0f0ae-2172d7dbbfe453ea81ebf0b4e62d8101a7d5d1f0.tar.gz
master-31e0f0ae-2172d7dbbfe453ea81ebf0b4e62d8101a7d5d1f0.tar.bz2
master-31e0f0ae-2172d7dbbfe453ea81ebf0b4e62d8101a7d5d1f0.zip
x86: update to linux 4.4
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48216
Diffstat (limited to 'target/linux/x86/patches-4.4')
-rw-r--r--target/linux/x86/patches-4.4/011-tune_lzma_options.patch22
-rw-r--r--target/linux/x86/patches-4.4/120-panic_on_unrecovered_nmi.patch11
2 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/x86/patches-4.4/011-tune_lzma_options.patch b/target/linux/x86/patches-4.4/011-tune_lzma_options.patch
new file mode 100644
index 0000000000..9fe0ad2235
--- /dev/null
+++ b/target/linux/x86/patches-4.4/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -324,7 +324,7 @@
+
+ quiet_cmd_lzma = LZMA $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ (rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -23,7 +23,7 @@
+ #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ #define BOOT_HEAP_SIZE 0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */
+
diff --git a/target/linux/x86/patches-4.4/120-panic_on_unrecovered_nmi.patch b/target/linux/x86/patches-4.4/120-panic_on_unrecovered_nmi.patch
new file mode 100644
index 0000000000..81cef53a66
--- /dev/null
+++ b/target/linux/x86/patches-4.4/120-panic_on_unrecovered_nmi.patch
@@ -0,0 +1,11 @@
+--- a/drivers/mfd/rdc321x-southbridge.c
++++ b/drivers/mfd/rdc321x-southbridge.c
+@@ -85,6 +85,8 @@
+ rdc321x_gpio_pdata.sb_pdev = pdev;
+ rdc321x_wdt_pdata.sb_pdev = pdev;
+
++ panic_on_unrecovered_nmi = 1;
++
+ return mfd_add_devices(&pdev->dev, -1,
+ rdc321x_sb_cells, ARRAY_SIZE(rdc321x_sb_cells),
+ NULL, 0, NULL);