summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-04-10 14:43:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-04-10 14:43:17 +0000
commitf02e3a2a4a656aa550ad37e3c547a309872a011d (patch)
tree1e45c4ef87082267df7f56dd6d6ff3fa97144dd5 /target/linux/x86/image
parent8a7a02bd2e98f807ebf8d0c0deb63fab04d055cc (diff)
downloadmaster-31e0f0ae-f02e3a2a4a656aa550ad37e3c547a309872a011d.tar.gz
master-31e0f0ae-f02e3a2a4a656aa550ad37e3c547a309872a011d.tar.bz2
master-31e0f0ae-f02e3a2a4a656aa550ad37e3c547a309872a011d.zip
x86: try harder to attach block2mtd to fix boot issues on devices with longer delays
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40444
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 4b40e64de7..03aa350da2 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -53,15 +53,15 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
+ block2mtd.block2mtd=$(ROOTPART),131072,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
endef
define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=squashfs rootwait
endef
define Image/Build/grub2