summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-05-17 10:35:14 +0000
committerJohn Crispin <john@openwrt.org>2011-05-17 10:35:14 +0000
commitdfc19a34b4ac9f5ad1aec67a2353895c8ef1ecd5 (patch)
tree6c247105cbc29fd73f0146028301e88fb0e608f0 /target/linux/x86/image
parent9abcc013059c05da2f8ce918981f24bb92ea8014 (diff)
downloadmaster-31e0f0ae-dfc19a34b4ac9f5ad1aec67a2353895c8ef1ecd5.tar.gz
master-31e0f0ae-dfc19a34b4ac9f5ad1aec67a2353895c8ef1ecd5.tar.bz2
master-31e0f0ae-dfc19a34b4ac9f5ad1aec67a2353895c8ef1ecd5.zip
* adds support for Artec Thincan
Signed-of-By: Lauri Võsandi <lauri.vosandi@gmail.com> SVN-Revision: 26919
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Config.in15
-rw-r--r--target/linux/x86/image/Makefile7
2 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/x86/image/Config.in b/target/linux/x86/image/Config.in
index 4847dd4ae5..3ceae05f36 100644
--- a/target/linux/x86/image/Config.in
+++ b/target/linux/x86/image/Config.in
@@ -1,3 +1,18 @@
+config X86_ETHERBOOT_IMAGES
+ bool "Build Etherboot image"
+ depends TARGET_x86 && TARGET_x86_thincan_DBE61
+ default y
+ help
+ Builds network bootable image for ThinCan DBE61 (Etherboot BIOS)
+
+config X86_ETHERBOOT_BOOTOPTS
+ string "Extra kernel boot options"
+ depends X86_ETHERBOOT_IMAGES
+ default "ip=dhcp nbdport=2000 " if TARGET_ROOTFS_SQUASHFS
+ default "ip=dhcp root=/dev/nfs nfsroot=192.168.0.1:/srv/dbe61"
+ help
+ Kernel arguments to pass to the kernel eg. NFS root location etc.
+
config X86_GRUB_IMAGES
bool "Build GRUB images (Linux x86 or x86_64 host only)"
depends TARGET_x86 && !TARGET_x86_olpc
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 12ffe18553..c070a10319 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -166,6 +166,13 @@ endif
define Image/BuildKernel
$(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
+ ifneq ($(CONFIG_X86_ETHERBOOT_IMAGES),)
+ rm -f $(BIN_DIR)/$(IMG_PREFIX)-etherboot
+ $(STAGING_DIR_HOST)/bin/mkelfImage \
+ --append=$(CONFIG_X86_ETHERBOOT_BOOTOPTS) \
+ $(KDIR)/bzImage \
+ $(BIN_DIR)/$(IMG_PREFIX)-etherboot
+ endif
endef
define Image/Prepare