summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-28 11:37:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-28 11:37:08 +0000
commit742700719303feedac8f98fd801c0ef769c52ead (patch)
tree5b753c4c0c90fc3a0e6dbe30733bddbc55d0c5d4 /target/linux/x86/image
parent518d2b90e644b041259ab796aab0e2469789713d (diff)
downloadmaster-31e0f0ae-742700719303feedac8f98fd801c0ef769c52ead.tar.gz
master-31e0f0ae-742700719303feedac8f98fd801c0ef769c52ead.tar.bz2
master-31e0f0ae-742700719303feedac8f98fd801c0ef769c52ead.zip
x86: remove the olpc subtarget, it has been unmaintained for a long time
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45083
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Config.in6
-rw-r--r--target/linux/x86/image/Makefile34
-rwxr-xr-xtarget/linux/x86/image/gen_image_olpc.sh35
-rw-r--r--target/linux/x86/image/olpc.fth5
4 files changed, 0 insertions, 80 deletions
diff --git a/target/linux/x86/image/Config.in b/target/linux/x86/image/Config.in
index d2ef9fb7fa..f232c647a5 100644
--- a/target/linux/x86/image/Config.in
+++ b/target/linux/x86/image/Config.in
@@ -12,9 +12,3 @@ config X86_ETHERBOOT_BOOTOPTS
default "ip=dhcp root=/dev/nfs nfsroot=192.168.0.1:/srv/dbe61"
help
Kernel arguments to pass to the kernel eg. NFS root location etc.
-
-config OLPC_BOOTSCRIPT_IMAGES
- bool "Build images with bootscript"
- depends on TARGET_x86_olpc
- depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
- default TARGET_x86_olpc
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 85460206c0..ffda5c1578 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -100,38 +100,6 @@ endif
ROOTDELAY=10
-ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
-
- define Image/cmdline/ext4
- root=$(ROOTPART) rootfstype=ext4 rootwait
- endef
-
- define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
- endef
-
- define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
- endef
-
- define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootdelay=$(ROOTDELAY)
- endef
-
- define Image/Build/bootscript
- # left here because the image builder doesnt need these
- $(INSTALL_DIR) $(KDIR)/root.bootscript/boot
- $(CP) $(KDIR)/bzImage $(KDIR)/root.bootscript/boot/vmlinuz
- sed -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
- ./olpc.fth > $(KDIR)/root.bootscript/boot/olpc.fth
- PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_olpc.sh \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
- $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.bootscript \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
- endef
-
-endif
-
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef
@@ -239,7 +207,6 @@ endef
define Image/Prepare
$(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
- $(call Image/Prepare/bootscript)
$(call Image/Prepare/grub2)
endef
@@ -249,7 +216,6 @@ endef
define Image/Build
$(call Image/Build/$(1))
- $(call Image/Build/bootscript,$(1))
ifneq ($(1),iso)
$(call Image/Build/grub2,$(1))
$(call Image/Build/vdi,$(1))
diff --git a/target/linux/x86/image/gen_image_olpc.sh b/target/linux/x86/image/gen_image_olpc.sh
deleted file mode 100755
index 82bc4ed957..0000000000
--- a/target/linux/x86/image/gen_image_olpc.sh
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/usr/bin/env bash
-# Copyright (C) 2006-2010 OpenWrt.org
-set -x
-[ $# == 5 ] || {
- echo "SYNTAX: $0 <file> <kernel size> <kernel directory> <rootfs size> <rootfs image>"
- exit 1
-}
-
-OUTPUT="$1"
-KERNELSIZE="$2"
-KERNELDIR="$3"
-ROOTFSSIZE="$4"
-ROOTFSIMAGE="$5"
-
-rm -f "$OUTPUT"
-
-head=16
-sect=63
-cyl=$(( ($KERNELSIZE + $ROOTFSSIZE) * 1024 * 1024 / ($head * $sect * 512)))
-
-# create partition table
-set `ptgen -o "$OUTPUT" -h $head -s $sect -p ${KERNELSIZE}m -p ${ROOTFSSIZE}m`
-
-KERNELOFFSET="$(($1 / 512))"
-KERNELSIZE="$(($2 / 512))"
-ROOTFSOFFSET="$(($3 / 512))"
-ROOTFSSIZE="$(($4 / 512))"
-
-BLOCKS="$((($KERNELSIZE / 2) - 1))"
-
-genext2fs -d "$KERNELDIR" -b "$BLOCKS" "$OUTPUT.kernel"
-dd if="$OUTPUT.kernel" of="$OUTPUT" bs=512 seek="$KERNELOFFSET" conv=notrunc
-[ -n "$PADDING" ] && dd if=/dev/zero of="$OUTPUT" bs=512 seek="$ROOTFSOFFSET" conv=notrunc count="$ROOTFSSIZE"
-dd if="$ROOTFSIMAGE" of="$OUTPUT" bs=512 seek="$ROOTFSOFFSET" conv=notrunc
-rm -f "$OUTPUT.kernel"
diff --git a/target/linux/x86/image/olpc.fth b/target/linux/x86/image/olpc.fth
deleted file mode 100644
index 5914be6606..0000000000
--- a/target/linux/x86/image/olpc.fth
+++ /dev/null
@@ -1,5 +0,0 @@
-\ Boot script
-" u:\boot\vmlinuz" to boot-device
-" @CMDLINE@ noinitrd console=ttyS0,115200 console=tty0" to boot-file
-unfreeze
-boot