summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-23 09:59:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-23 09:59:56 +0000
commit493b7c7f3cb300944453b110f5098a950053fd4b (patch)
tree41fdba9dc2522f4785cf91d3bac8400a2ac229e0 /target/linux/x86/image
parented2bf29be5ea97f67c7195cd02eaf1bc1515bd36 (diff)
downloadmaster-31e0f0ae-493b7c7f3cb300944453b110f5098a950053fd4b.tar.gz
master-31e0f0ae-493b7c7f3cb300944453b110f5098a950053fd4b.tar.bz2
master-31e0f0ae-493b7c7f3cb300944453b110f5098a950053fd4b.zip
x86: avoid using grub prepare when using grub2
SVN-Revision: 33525
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index ebe0788593..547f0839fd 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -237,7 +237,7 @@ endef
define Image/Prepare
$(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
$(call Image/Prepare/bootscript)
- $(call Image/Prepare/grub)
+ $(call Image/Prepare/$(if $(CONFIG_X86_USE_GRUB2),grub2,grub))
endef
define Image/Build