summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-11-22 12:12:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-11-22 12:12:39 +0000
commit4052849677922574480dc534f2e6171571df4b67 (patch)
tree95207819a2525e85e3d08b8aca7c598291553e73 /target/linux/x86/image
parent67d797821c2c20fcd5b56044625ca281b2ab8548 (diff)
downloadmaster-31e0f0ae-4052849677922574480dc534f2e6171571df4b67.tar.gz
master-31e0f0ae-4052849677922574480dc534f2e6171571df4b67.tar.bz2
master-31e0f0ae-4052849677922574480dc534f2e6171571df4b67.zip
switch from ext2 to ext4 (w/o) journaling
SVN-Revision: 24084
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Config.in8
-rw-r--r--target/linux/x86/image/Makefile14
2 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/x86/image/Config.in b/target/linux/x86/image/Config.in
index 8467f48a4f..3557e63c2f 100644
--- a/target/linux/x86/image/Config.in
+++ b/target/linux/x86/image/Config.in
@@ -1,7 +1,7 @@
config X86_GRUB_IMAGES
bool "Build GRUB images (Linux x86 or x86_64 host only)"
depends TARGET_x86 && !TARGET_x86_olpc
- depends TARGET_ROOTFS_EXT2FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
+ depends TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
select PACKAGE_grub
default y
@@ -35,21 +35,21 @@ config X86_VDI_IMAGES
bool "Build VirtualBox image files (VDI)"
depends X86_GRUB_IMAGES
depends TARGET_x86_generic
- depends TARGET_ROOTFS_EXT2FS
+ depends TARGET_ROOTFS_EXT4FS
select PACKAGE_kmod-pcnet32
config X86_VMDK_IMAGES
bool "Build VMware image files (VMDK)"
depends X86_GRUB_IMAGES
depends TARGET_x86_generic
- depends TARGET_ROOTFS_EXT2FS
+ depends TARGET_ROOTFS_EXT4FS
select PACKAGE_kmod-e1000
config OLPC_BOOTSCRIPT_IMAGES
bool "Build images with bootscript"
depends TARGET_x86_olpc
- depends TARGET_ROOTFS_EXT2FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
+ depends TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
config TARGET_IMAGES_PAD
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index b5297bbff8..57d7b0b46d 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -35,8 +35,8 @@ ifneq ($(CONFIG_X86_GRUB_IMAGES),)
BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
- define Image/cmdline/ext2
- root=$(ROOTPART) rootfstype=ext2 rootwait
+ define Image/cmdline/ext4
+ root=$(ROOTPART) rootfstype=ext4 rootwait
endef
define Image/cmdline/jffs2-64k
@@ -88,8 +88,8 @@ ROOTDELAY=10
ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
- define Image/cmdline/ext2
- root=$(ROOTPART) rootfstype=ext2 rootwait
+ define Image/cmdline/ext4
+ root=$(ROOTPART) rootfstype=ext4 rootwait
endef
define Image/cmdline/jffs2-64k
@@ -141,7 +141,7 @@ endef
ifneq ($(CONFIG_X86_VDI_IMAGES),)
define Image/Build/vdi
# left here because the image builder doesnt need these
- ifeq ($(1),ext2)
+ ifeq ($(1),ext4)
rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
qemu-img convert -f raw -O vdi \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
@@ -155,7 +155,7 @@ endif
ifneq ($(CONFIG_X86_VMDK_IMAGES),)
define Image/Build/vmdk
# left here because the image builder doesnt need these
- ifeq ($(1),ext2)
+ ifeq ($(1),ext4)
rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
qemu-img convert -f raw -O vmdk \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
@@ -184,7 +184,7 @@ define Image/Build
endif
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
$(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
- ifeq ($(1),ext2)
+ ifeq ($(1),ext4)
gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
endif