summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-08-10 18:35:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-08-10 18:35:29 +0000
commit09f4018b2ede9dc04e5d17cfa53e74f4756daf43 (patch)
tree0a14b85a48eb44d2aa6d0c6fcb0516c48c278a07 /target/linux/x86/image
parent7b05fe59a459976cd63bc77d9593d5ac0fc9e90a (diff)
downloadmaster-31e0f0ae-09f4018b2ede9dc04e5d17cfa53e74f4756daf43.tar.gz
master-31e0f0ae-09f4018b2ede9dc04e5d17cfa53e74f4756daf43.tar.bz2
master-31e0f0ae-09f4018b2ede9dc04e5d17cfa53e74f4756daf43.zip
x86: Fix CONFIG_X86_GRUB_SERIAL=""
With .config:CONFIG_X86_GRUB_SERIAL="" which (AFAICT) is the way to tell GRUB not to use a serial console, in target/linux/x86/image/Makefile:ifneq ($(CONFIG_X86_GRUB_SERIAL),) $(CONFIG_X86_GRUB_SERIAL) expands to `""' (a literal double double-quote), making the condition unconditionally false. This patch fixes the situation by passing CONFIG_X86_GRUB_SERIAL through qstrip before testing. Signed-off-by: Tamas TEVESZ <ice@extreme.hu> SVN-Revision: 37749
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 039d70ab82..d3ada9fad2 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -28,8 +28,10 @@ ifneq ($(CONFIG_X86_GRUB_CONSOLE),)
GRUB_TERMINALS += console
endif
-ifneq ($(CONFIG_X86_GRUB_SERIAL),)
- GRUB_CONSOLE_CMDLINE += console=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL)),$(CONFIG_X86_GRUB_BAUDRATE)n8
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL))
+
+ifneq ($(GRUB_SERIAL),)
+ GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_X86_GRUB_BAUDRATE)n8
GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_X86_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
GRUB_TERMINALS += serial
endif