summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-12 17:39:04 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-12 17:39:04 +0200
commit2e5f84fc10a5feeb1bb6a9805904b93ff6dc24bb (patch)
treef98c507cdd913f5966956402fa3b99c3a0107f7b /target/linux/x86/image/Makefile
parentca12fd431d8dc03e182e3e34a18e1efe65b0111c (diff)
downloadmaster-31e0f0ae-2e5f84fc10a5feeb1bb6a9805904b93ff6dc24bb.tar.gz
master-31e0f0ae-2e5f84fc10a5feeb1bb6a9805904b93ff6dc24bb.tar.bz2
master-31e0f0ae-2e5f84fc10a5feeb1bb6a9805904b93ff6dc24bb.zip
x86: remove legacy script/makefile code for rdc devices
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile24
1 files changed, 0 insertions, 24 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 64a5e058cb..98c2150e52 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -181,30 +181,6 @@ define Image/BuildKernel
endif
endef
-define Image/Build/Profile/ar525w
- cp $(KDIR)/bzImage $(KDIR)/bzImage.tmp
- $(SCRIPT_DIR)/pad_image $(1) $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) 32
- $(STAGING_DIR_HOST)/bin/airlink -b 1 $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) \
- $(BIN_DIR)/$(IMG_PREFIX)-$(1)-ar525w.img
- $(STAGING_DIR_HOST)/bin/airlink -e -b 1 $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) \
- $(BIN_DIR)/$(IMG_PREFIX)-$(1)-ar525w-web.img
-endef
-
-define Image/Build/Profile/sitecom
- cp $(KDIR)/bzImage $(KDIR)/bzImage.tmp
- #32k config data + 20 bytes header + 2 bytes checksum after kernel image
- $(SCRIPT_DIR)/pad_image $(1) $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) 32790
- $(TOPDIR)/target/linux/rdc/image/mkimg_sitecom.pl $(KDIR)/bzImage.tmp > $(KDIR)/tmp.img
- cat $(KDIR)/root.$(1) >> $(KDIR)/tmp.img
- cp $(KDIR)/tmp.img $(BIN_DIR)/$(IMG_PREFIX)-$(1)-sitecom.img
- rm $(KDIR)/tmp.img $(KDIR)/bzImage.tmp
-endef
-
-define Image/Build/Profile/bifferboard
- $(TOPDIR)/target/linux/rdc/image/mkimg_bifferboard.py $(KDIR)/bzImage $(KDIR)/root.$(1) \
- $(BIN_DIR)/$(IMG_PREFIX)-$(1)-bifferboard.img
-endef
-
define Image/Prepare
$(call Image/Prepare/grub2)
endef