summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/generic/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-10-04 20:58:11 +0000
committerJohn Crispin <john@openwrt.org>2007-10-04 20:58:11 +0000
commit9e8f2ca1f0d1fe2ea5688c466f2f8b40a5e870c2 (patch)
tree3fc839823edcd9cb20fb3e7f7c0b4eaf14df1714 /target/linux/x86/generic/profiles
parent5f87e72dae8c79fd047d95a7cf9fca55b71a7299 (diff)
downloadmaster-31e0f0ae-9e8f2ca1f0d1fe2ea5688c466f2f8b40a5e870c2.tar.gz
master-31e0f0ae-9e8f2ca1f0d1fe2ea5688c466f2f8b40a5e870c2.tar.bz2
master-31e0f0ae-9e8f2ca1f0d1fe2ea5688c466f2f8b40a5e870c2.zip
added subtargets to x86
SVN-Revision: 9128
Diffstat (limited to 'target/linux/x86/generic/profiles')
-rw-r--r--target/linux/x86/generic/profiles/000-Generic.mk16
-rw-r--r--target/linux/x86/generic/profiles/Soekris.mk16
2 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/x86/generic/profiles/000-Generic.mk b/target/linux/x86/generic/profiles/000-Generic.mk
new file mode 100644
index 0000000000..d7e6b7eb1e
--- /dev/null
+++ b/target/linux/x86/generic/profiles/000-Generic.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+ PACKAGES:=
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/generic/profiles/Soekris.mk b/target/linux/x86/generic/profiles/Soekris.mk
new file mode 100644
index 0000000000..8cce126039
--- /dev/null
+++ b/target/linux/x86/generic/profiles/Soekris.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Soekris
+ NAME:=Soekris Net4801
+ PACKAGES:=kmod-i2c-scx200 kmod-natsemi kmod-leds-net48xx kmod-scx200-gpio kmod-scx200-wdt kmod-hwmon-pc87360
+endef
+
+define Profile/Soekris/Description
+ Package set compatible with the Soekris Net4801. Contains I2C/LEDS/GPIO/Sensors support
+endef
+$(eval $(call Profile,Soekris))