summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit6a4f2922f6303a006d66b4bbb79541823b1c12b4 (patch)
treed3d9644c2a4a2e9b758bab9b84973e078143ed2c /target/linux/x86/Makefile
parenteab95ea46736f8359c5a19a612f0e39160cab80c (diff)
downloadmaster-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.gz
master-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.bz2
master-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37049
Diffstat (limited to 'target/linux/x86/Makefile')
-rw-r--r--target/linux/x86/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 920f946254..0d4fe4764f 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -15,6 +15,8 @@ SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
LINUX_VERSION:=3.3.8
+KERNELNAME:=bzImage
+
include $(INCLUDE_DIR)/target.mk
$(eval $(call BuildTarget))