summaryrefslogtreecommitdiffstats
path: root/target/linux/x86-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-25 18:20:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-25 18:20:34 +0000
commit653f61fb3eb23d5cd30e1577190af038a6a47fbd (patch)
tree999ecb0f73415ee1aba71780780f271a384973ab /target/linux/x86-2.6
parent738ca6f6571b30c80c5e64d2c40b0b3630ec3c29 (diff)
downloadmaster-31e0f0ae-653f61fb3eb23d5cd30e1577190af038a6a47fbd.tar.gz
master-31e0f0ae-653f61fb3eb23d5cd30e1577190af038a6a47fbd.tar.bz2
master-31e0f0ae-653f61fb3eb23d5cd30e1577190af038a6a47fbd.zip
clean up a few things in image build makefiles and fix unnecessary grub rebuilds
SVN-Revision: 6360
Diffstat (limited to 'target/linux/x86-2.6')
-rw-r--r--target/linux/x86-2.6/image/grub/Makefile36
1 files changed, 10 insertions, 26 deletions
diff --git a/target/linux/x86-2.6/image/grub/Makefile b/target/linux/x86-2.6/image/grub/Makefile
index 365b327622..d37803012c 100644
--- a/target/linux/x86-2.6/image/grub/Makefile
+++ b/target/linux/x86-2.6/image/grub/Makefile
@@ -23,34 +23,19 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/grub-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
ifeq ($(HOST_ARCH),x86_64)
- define Build/Configure
- (cd $(PKG_BUILD_DIR); \
- LDFLAGS="-static" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- $(DISABLE_NLS) \
- --disable-auto-linux-mem-opt \
- )
- endef
+CONFIGURE_FLAGS:= \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME)
else
- define Build/Configure
+CONFIGURE_FLAGS:=
+endif
+
+define Build/Configure
(cd $(PKG_BUILD_DIR); \
LDFLAGS="-static" \
./configure \
+ $(CONFIGURE_FLAGS) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
@@ -66,8 +51,7 @@ else
$(DISABLE_NLS) \
--disable-auto-linux-mem-opt \
)
- endef
-endif
+endef
#
# ./configure detects whether the host compiler supports