summaryrefslogtreecommitdiffstats
path: root/target/linux/uml
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-11-21 14:28:33 +0000
committerNicolas Thill <nico@openwrt.org>2011-11-21 14:28:33 +0000
commitc33f21ae9508d680be26ef6f9ed3f5883af8d67b (patch)
tree2a4b9262688799433447c6ce15845c19e59d20ec /target/linux/uml
parent16c583531a7099b6869261e96ff33580539fda12 (diff)
downloadmaster-31e0f0ae-c33f21ae9508d680be26ef6f9ed3f5883af8d67b.tar.gz
master-31e0f0ae-c33f21ae9508d680be26ef6f9ed3f5883af8d67b.tar.bz2
master-31e0f0ae-c33f21ae9508d680be26ef6f9ed3f5883af8d67b.zip
target/uml: export atomic64_* functions on 32-bit x86
SVN-Revision: 29287
Diffstat (limited to 'target/linux/uml')
-rw-r--r--target/linux/uml/patches-3.0/004-fix_atomic64_32.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/uml/patches-3.0/004-fix_atomic64_32.patch b/target/linux/uml/patches-3.0/004-fix_atomic64_32.patch
new file mode 100644
index 0000000000..6901eee210
--- /dev/null
+++ b/target/linux/uml/patches-3.0/004-fix_atomic64_32.patch
@@ -0,0 +1,13 @@
+[patch] um: export atomic64_* functions on i386
+
+--- a/arch/um/sys-i386/Makefile
++++ b/arch/um/sys-i386/Makefile
+@@ -8,7 +8,7 @@ obj-y = bug.o bugs.o checksum.o delay.o
+
+ obj-$(CONFIG_BINFMT_ELF) += elfcore.o
+
+-subarch-obj-y = lib/semaphore_32.o lib/string_32.o
++subarch-obj-y = lib/atomic64_32.o lib/semaphore_32.o lib/string_32.o
+ subarch-obj-$(CONFIG_HIGHMEM) += mm/highmem_32.o
+ subarch-obj-$(CONFIG_MODULES) += kernel/module.o
+