summaryrefslogtreecommitdiffstats
path: root/target/linux/uml
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-05-02 07:57:25 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-05-02 07:57:25 +0000
commita18ec3c37e1362c202b50da1975c3f9c11450584 (patch)
tree12b11b177cc914b3f0242a914d20a9b777fddc2a /target/linux/uml
parentaf53fa1d91e84f4d7cca1b125bf37b1de798449d (diff)
downloadmaster-31e0f0ae-a18ec3c37e1362c202b50da1975c3f9c11450584.tar.gz
master-31e0f0ae-a18ec3c37e1362c202b50da1975c3f9c11450584.tar.bz2
master-31e0f0ae-a18ec3c37e1362c202b50da1975c3f9c11450584.zip
update to 2.6.38
SVN-Revision: 26803
Diffstat (limited to 'target/linux/uml')
-rw-r--r--target/linux/uml/Makefile2
-rw-r--r--target/linux/uml/config/i3861
-rw-r--r--target/linux/uml/config/x86_641
-rw-r--r--target/linux/uml/patches-2.6.38/001-gcc4_unit_at_a_time_i386_fix.patch11
-rw-r--r--target/linux/uml/patches-2.6.38/002-gcc4_unfortify_source.patch21
-rw-r--r--target/linux/uml/patches-2.6.38/006-uml_libc_link_errors.patch24
-rw-r--r--target/linux/uml/patches-2.6.38/901-lib_zlib_deflate_visible.patch14
7 files changed, 73 insertions, 1 deletions
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index 9342b1fa90..442b71656c 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -22,7 +22,7 @@ BOARD:=uml
BOARDNAME:=User Mode Linux
FEATURES:=ext4 audio
-LINUX_VERSION:=2.6.37.6
+LINUX_VERSION:=2.6.38.2
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/uml/config/i386 b/target/linux/uml/config/i386
index fb2b0cb251..71246861cd 100644
--- a/target/linux/uml/config/i386
+++ b/target/linux/uml/config/i386
@@ -101,6 +101,7 @@ CONFIG_POSIX_MQUEUE_SYSCTL=y
# CONFIG_PREEMPT_RCU is not set
CONFIG_PRINT_QUOTA_WARNING=y
CONFIG_PROC_PAGE_MONITOR=y
+# CONFIG_PROCESSOR_SELECT is not set
CONFIG_PTY_CHAN=y
CONFIG_QFMT_V1=y
CONFIG_QFMT_V2=y
diff --git a/target/linux/uml/config/x86_64 b/target/linux/uml/config/x86_64
index 006f454168..39445c269a 100644
--- a/target/linux/uml/config/x86_64
+++ b/target/linux/uml/config/x86_64
@@ -82,6 +82,7 @@ CONFIG_POSIX_MQUEUE_SYSCTL=y
# CONFIG_PREEMPT_RCU is not set
# CONFIG_PRINT_QUOTA_WARNING is not set
CONFIG_PROC_PAGE_MONITOR=y
+# CONFIG_PROCESSOR_SELECT is not set
CONFIG_PTY_CHAN=y
CONFIG_QFMT_V1=y
CONFIG_QFMT_V2=y
diff --git a/target/linux/uml/patches-2.6.38/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-2.6.38/001-gcc4_unit_at_a_time_i386_fix.patch
new file mode 100644
index 0000000000..442c0ec76e
--- /dev/null
+++ b/target/linux/uml/patches-2.6.38/001-gcc4_unit_at_a_time_i386_fix.patch
@@ -0,0 +1,11 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
+ # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
+ # a lot more stack due to the lack of sharing of stacklots. Also, gcc
+ # 4.3.0 needs -funit-at-a-time for extern inline functions.
+-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+
diff --git a/target/linux/uml/patches-2.6.38/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.38/002-gcc4_unfortify_source.patch
new file mode 100644
index 0000000000..2be33d02a3
--- /dev/null
+++ b/target/linux/uml/patches-2.6.38/002-gcc4_unfortify_source.patch
@@ -0,0 +1,21 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
++
+ KBUILD_CFLAGS += $(cflags-y)
+--- a/arch/um/Makefile-x86_64
++++ b/arch/um/Makefile-x86_64
+@@ -24,3 +24,7 @@ LINK-y += -m64
+
+ # Do unit-at-a-time unconditionally on x86_64, following the host
+ KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
++
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
diff --git a/target/linux/uml/patches-2.6.38/006-uml_libc_link_errors.patch b/target/linux/uml/patches-2.6.38/006-uml_libc_link_errors.patch
new file mode 100644
index 0000000000..0bab54c0ba
--- /dev/null
+++ b/target/linux/uml/patches-2.6.38/006-uml_libc_link_errors.patch
@@ -0,0 +1,24 @@
+--- a/arch/um/kernel/uml.lds.S
++++ b/arch/um/kernel/uml.lds.S
+@@ -35,6 +35,21 @@ SECTIONS
+ *(.gnu.warning)
+ *(.gnu.linkonce.t*)
+ }
++ /* Deal with multilib libc */
++ .rel.plt :
++ {
++ *(.rel.plt)
++ PROVIDE_HIDDEN (__rel_iplt_start = .);
++ *(.rel.iplt)
++ PROVIDE_HIDDEN (__rel_iplt_end = .);
++ }
++ .rela.plt :
++ {
++ *(.rela.plt)
++ PROVIDE_HIDDEN (__rela_iplt_start = .);
++ *(.rela.iplt)
++ PROVIDE_HIDDEN (__rela_iplt_end = .);
++ }
+
+ . = ALIGN(PAGE_SIZE);
+ .syscall_stub : {
diff --git a/target/linux/uml/patches-2.6.38/901-lib_zlib_deflate_visible.patch b/target/linux/uml/patches-2.6.38/901-lib_zlib_deflate_visible.patch
new file mode 100644
index 0000000000..f4aba9bd7a
--- /dev/null
+++ b/target/linux/uml/patches-2.6.38/901-lib_zlib_deflate_visible.patch
@@ -0,0 +1,14 @@
+make ZLIB_DEFLATE visible, so that we can choose whether we want it built-in
+or as a module
+
+--- a/lib/Kconfig
++++ b/lib/Kconfig
+@@ -98,7 +98,7 @@ config ZLIB_INFLATE
+ tristate
+
+ config ZLIB_DEFLATE
+- tristate
++ tristate "Zlib compression"
+
+ config LZO_COMPRESS
+ tristate