summaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-08-16 10:18:07 +0000
committerNicolas Thill <nico@openwrt.org>2009-08-16 10:18:07 +0000
commit0eeb0d3c2f9029e2be2ea36e218ac3052cb88e08 (patch)
treef3aebaad2d3424b15b4faecc63597bdd4d1d86dc /target/linux/uml/patches
parent149f92b47ac87199df6c81e5ca90b6d47e5359da (diff)
downloadmaster-31e0f0ae-0eeb0d3c2f9029e2be2ea36e218ac3052cb88e08.tar.gz
master-31e0f0ae-0eeb0d3c2f9029e2be2ea36e218ac3052cb88e08.tar.bz2
master-31e0f0ae-0eeb0d3c2f9029e2be2ea36e218ac3052cb88e08.zip
bump to 2.6.30.4, apply fix from [15119] to x86_64
SVN-Revision: 17285
Diffstat (limited to 'target/linux/uml/patches')
-rw-r--r--target/linux/uml/patches/002-gcc4_unfortify_source.patch10
-rw-r--r--target/linux/uml/patches/901-lib_zlib_deflate_visible.patch2
2 files changed, 11 insertions, 1 deletions
diff --git a/target/linux/uml/patches/002-gcc4_unfortify_source.patch b/target/linux/uml/patches/002-gcc4_unfortify_source.patch
index b13e5df521..2be33d02a3 100644
--- a/target/linux/uml/patches/002-gcc4_unfortify_source.patch
+++ b/target/linux/uml/patches/002-gcc4_unfortify_source.patch
@@ -9,3 +9,13 @@
+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
+
KBUILD_CFLAGS += $(cflags-y)
+--- a/arch/um/Makefile-x86_64
++++ b/arch/um/Makefile-x86_64
+@@ -24,3 +24,7 @@ LINK-y += -m64
+
+ # Do unit-at-a-time unconditionally on x86_64, following the host
+ KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
++
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
diff --git a/target/linux/uml/patches/901-lib_zlib_deflate_visible.patch b/target/linux/uml/patches/901-lib_zlib_deflate_visible.patch
index bac8fcfa97..b71a673314 100644
--- a/target/linux/uml/patches/901-lib_zlib_deflate_visible.patch
+++ b/target/linux/uml/patches/901-lib_zlib_deflate_visible.patch
@@ -3,7 +3,7 @@ or as a module
--- a/lib/Kconfig
+++ b/lib/Kconfig
-@@ -83,7 +83,7 @@ config ZLIB_INFLATE
+@@ -92,7 +92,7 @@ config ZLIB_INFLATE
tristate
config ZLIB_DEFLATE