summaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches-2.6.30/002-gcc4_unfortify_source.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-02-10 08:48:33 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-02-10 08:48:33 +0000
commite71f4e9df0bbb03f0ac14988ddb1478dc3b72d45 (patch)
tree4274fa26ce55866d31e44af10bdde89fa3e3a981 /target/linux/uml/patches-2.6.30/002-gcc4_unfortify_source.patch
parent6fd4369159b408b84fe0c41439c35b242c667e27 (diff)
downloadmaster-31e0f0ae-e71f4e9df0bbb03f0ac14988ddb1478dc3b72d45.tar.gz
master-31e0f0ae-e71f4e9df0bbb03f0ac14988ddb1478dc3b72d45.tar.bz2
master-31e0f0ae-e71f4e9df0bbb03f0ac14988ddb1478dc3b72d45.zip
move 2.6.30 patches to their appropriate directory
SVN-Revision: 19572
Diffstat (limited to 'target/linux/uml/patches-2.6.30/002-gcc4_unfortify_source.patch')
-rw-r--r--target/linux/uml/patches-2.6.30/002-gcc4_unfortify_source.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/uml/patches-2.6.30/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.30/002-gcc4_unfortify_source.patch
new file mode 100644
index 0000000000..2be33d02a3
--- /dev/null
+++ b/target/linux/uml/patches-2.6.30/002-gcc4_unfortify_source.patch
@@ -0,0 +1,21 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
++
+ KBUILD_CFLAGS += $(cflags-y)
+--- a/arch/um/Makefile-x86_64
++++ b/arch/um/Makefile-x86_64
+@@ -24,3 +24,7 @@ LINK-y += -m64
+
+ # Do unit-at-a-time unconditionally on x86_64, following the host
+ KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
++
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)