summaryrefslogtreecommitdiffstats
path: root/target/linux/uml-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
commit7a6a6464971c69fa1026aeaf8fad5c79250230e9 (patch)
treea68bcf07bd0d15b68d1b990877a55002585690b9 /target/linux/uml-2.6
parent927fb16abb41cfeeee4e97b4baed2d5ce036ca2e (diff)
downloadmaster-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.tar.gz
master-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.tar.bz2
master-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.zip
Add initial version of the new Image Builder It's still a bit rough in a few places, but it seems to work for Broadcom at least - other targets untested.
SVN-Revision: 6071
Diffstat (limited to 'target/linux/uml-2.6')
-rwxr-xr-xtarget/linux/uml-2.6/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/uml-2.6/image/Makefile b/target/linux/uml-2.6/image/Makefile
index 6af4b8b816..b7bd9e9e65 100755
--- a/target/linux/uml-2.6/image/Makefile
+++ b/target/linux/uml-2.6/image/Makefile
@@ -7,9 +7,13 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Image/Prepare
+ cp $(LINUX_DIR)/linux $(KDIR)/vmlinux.elf
+endef
+
define Image/Build
cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
- cp $(LINUX_DIR)/linux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
endef
$(eval $(call BuildImage))