summaryrefslogtreecommitdiffstats
path: root/target/linux/uml-2.6/image
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-11-28 20:14:41 +0000
committerMike Baker <mbm@openwrt.org>2006-11-28 20:14:41 +0000
commitc3c4dfb57beebd26c0534698b8687c2c7c94e1f5 (patch)
tree6ffc51e355fb56df1c38449e6c16711d0b27a29c /target/linux/uml-2.6/image
parent16edf83d62c8a8bc446b5d9a74de27c2dd4f3d8b (diff)
downloadmaster-31e0f0ae-c3c4dfb57beebd26c0534698b8687c2c7c94e1f5.tar.gz
master-31e0f0ae-c3c4dfb57beebd26c0534698b8687c2c7c94e1f5.tar.bz2
master-31e0f0ae-c3c4dfb57beebd26c0534698b8687c2c7c94e1f5.zip
move target/image/platform to target/linux/platform/image platform directories are now self contained
SVN-Revision: 5669
Diffstat (limited to 'target/linux/uml-2.6/image')
-rwxr-xr-xtarget/linux/uml-2.6/image/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/uml-2.6/image/Makefile b/target/linux/uml-2.6/image/Makefile
new file mode 100755
index 0000000000..6af4b8b816
--- /dev/null
+++ b/target/linux/uml-2.6/image/Makefile
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Build
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+ cp $(LINUX_DIR)/linux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
+endef
+
+$(eval $(call BuildImage))