summaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-02-02 22:25:05 +0000
committerZoltan Herpai <wigyori@uid0.hu>2016-02-02 22:25:05 +0000
commita9c21dd3956f515bfa56cd93f34b3661b82a4dbd (patch)
tree2fdc71efd2f23956e6f51063f64fdae56bcb55be /target/linux/sunxi
parent9237cebfc73fcfac523e4ecac624eb08ae94b911 (diff)
downloadmaster-31e0f0ae-a9c21dd3956f515bfa56cd93f34b3661b82a4dbd.tar.gz
master-31e0f0ae-a9c21dd3956f515bfa56cd93f34b3661b82a4dbd.tar.bz2
master-31e0f0ae-a9c21dd3956f515bfa56cd93f34b3661b82a4dbd.zip
sunxi: add support for Orange Pi Plus (H3)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 48618
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/Makefile2
-rw-r--r--target/linux/sunxi/image/Makefile6
-rw-r--r--target/linux/sunxi/profiles/orangepi_plus.mk18
3 files changed, 24 insertions, 2 deletions
diff --git a/target/linux/sunxi/Makefile b/target/linux/sunxi/Makefile
index fe18fc3a5f..27bb2fe748 100644
--- a/target/linux/sunxi/Makefile
+++ b/target/linux/sunxi/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013-2014 OpenWrt.org
+# Copyright (C) 2013-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 5a5c98a7c0..bda690e39c 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -107,6 +107,10 @@ define Image/Build/Profile/Linksprite_pcDuino3
$(call Image/Build/SDCard,$(1),sun7i-a20-pcduino3)
endef
+define Image/Build/Profile/orangepi_plus
+ $(call Image/Build/SDCard,$(1),sun8i-h3-orangepi-plus)
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
$(call Image/Build/Profile/$(PROFILE),$(1))
diff --git a/target/linux/sunxi/profiles/orangepi_plus.mk b/target/linux/sunxi/profiles/orangepi_plus.mk
new file mode 100644
index 0000000000..c83f508655
--- /dev/null
+++ b/target/linux/sunxi/profiles/orangepi_plus.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/orangepi_plus
+ NAME:=orangepi_plus
+ PACKAGES:=\
+ kmod-rtc-sunxi uboot-sunxi-xunlong_orangepi_plus
+endef
+
+define Profile/orangepi_plus/Description
+ Package set optimized for the OrangePi Plus (H3)
+endef
+
+$(eval $(call Profile,orangepi_plus))