summaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-27 15:34:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-27 15:34:48 +0000
commit43b5730c98ffd4758b204d4633f18053ce96ade5 (patch)
tree456ecf604b16ebac4a578efcfb938428d28cad02 /target/linux/sunxi
parent0cce8316d9d2b7872d64206c9e9d270b4895b6f8 (diff)
downloadmaster-31e0f0ae-43b5730c98ffd4758b204d4633f18053ce96ade5.tar.gz
master-31e0f0ae-43b5730c98ffd4758b204d4633f18053ce96ade5.tar.bz2
master-31e0f0ae-43b5730c98ffd4758b204d4633f18053ce96ade5.zip
sunxi: use common image prefix
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45788
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 3187a2df59..6fcd61f5db 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -52,7 +52,7 @@ define Image/Build/SDCard
rm -f $(KDIR)/boot.img
mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
- mcopy -i $(KDIR)/boot.img $(BIN_DIR)/uboot-sunxi-$(PROFILE)/openwrt-sunxi-$(PROFILE)-boot.scr ::boot.scr
+ mcopy -i $(KDIR)/boot.img $(BIN_DIR)/uboot-sunxi-$(PROFILE)/$(IMG_PREFIX)-$(PROFILE)-boot.scr ::boot.scr
mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(2).dtb ::dtb
mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
@@ -62,7 +62,7 @@ define Image/Build/SDCard
$(KDIR)/root.$(1) \
$(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE) \
- $(BIN_DIR)/uboot-sunxi-$(PROFILE)/openwrt-sunxi-$(PROFILE)-u-boot-with-spl.bin
+ $(BIN_DIR)/uboot-sunxi-$(PROFILE)/$(IMG_PREFIX)-$(PROFILE)-u-boot-with-spl.bin
endef
define Image/Build/Profile/A10-OLinuXino-Lime
@@ -125,7 +125,7 @@ define Image/Build
$(call Image/Build/$(1),$(1))
$(call Image/Build/Profile/$(PROFILE),$(1))
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
endef
$(eval $(call BuildImage))