summaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-01-09 16:19:21 +0000
committerZoltan Herpai <wigyori@uid0.hu>2016-01-09 16:19:21 +0000
commit24894e52bc688844dfc96fc80073f2ac3196f992 (patch)
tree6609d3c423d40fa695a40a102acaefcb73ac8265 /target/linux/sunxi
parent26c04e09a23a0365725d8ef41423606344de61b1 (diff)
downloadmaster-31e0f0ae-24894e52bc688844dfc96fc80073f2ac3196f992.tar.gz
master-31e0f0ae-24894e52bc688844dfc96fc80073f2ac3196f992.tar.bz2
master-31e0f0ae-24894e52bc688844dfc96fc80073f2ac3196f992.zip
sunxi: prep module support options for 4.4
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 48160
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/modules.mk22
1 files changed, 14 insertions, 8 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index 3e8f4ba71a..6f4991798d 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -25,7 +25,7 @@ $(eval $(call KernelPackage,rtc-sunxi))
define KernelPackage/sunxi-ir
SUBMENU:=$(OTHER_MENU)
TITLE:=Sunxi SoC built-in IR support (A20)
- DEPENDS:=@TARGET_sunxi +kmod-input-core
+ DEPENDS:=@TARGET_sunxi @!LINUX_4_4 +kmod-input-core
$(call AddDepends/rtc)
KCONFIG:= \
CONFIG_MEDIA_SUPPORT=y \
@@ -45,7 +45,7 @@ $(eval $(call KernelPackage,sunxi-ir))
define KernelPackage/eeprom-sunxi
SUBMENU:=$(OTHER_MENU)
TITLE:=AllWinner Security ID fuse support
- DEPENDS:=@TARGET_sunxi
+ DEPENDS:=@TARGET_sunxi @!LINUX_4_4
KCONFIG:= \
CONFIG_EEPROM_SUNXI_SID
FILES:=$(LINUX_DIR)/drivers/misc/eeprom/sunxi_sid.ko
@@ -76,7 +76,7 @@ $(eval $(call KernelPackage,ata-sunxi))
define KernelPackage/sun4i-emac
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=AllWinner EMAC Ethernet support
- DEPENDS:=@TARGET_sunxi
+ DEPENDS:=@TARGET_sunxi +LINUX_4_4:kmod-of-mdio +LINUX_4_4:kmod-libphy
KCONFIG:=CONFIG_SUN4I_EMAC
FILES:=$(LINUX_DIR)/drivers/net/ethernet/allwinner/sun4i-emac.ko
AUTOLOAD:=$(call AutoProbe,sun4i-emac)
@@ -104,11 +104,17 @@ $(eval $(call KernelPackage,wdt-sunxi))
define KernelPackage/sound-soc-sunxi
TITLE:=AllWinner built-in SoC sound support
KCONFIG:= \
- CONFIG_SND_SUNXI_SOC_CODEC
- FILES:= \
- $(LINUX_DIR)/sound/soc/sunxi/sunxi-codec.ko
+ CONFIG_SND_SUNXI_SOC_CODEC \
+ CONFIG_SND_SUN4I_CODEC
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,4.4.0)),1)
+ FILES+=$(LINUX_DIR)/sound/soc/sunxi/sunxi-codec.ko
AUTOLOAD:=$(call AutoLoad,65,sunxi-codec)
- DEPENDS:=@TARGET_sunxi +kmod-sound-soc-core @LINUX_4_1
+endif
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,4.4.0)),1)
+ FILES:=$(LINUX_DIR)/sound/soc/sunxi/sun4i-codec.ko
+ AUTOLOAD:=$(call AutoLoad,65,sun4i-codec)
+endif
+ DEPENDS:=@TARGET_sunxi +kmod-sound-soc-core
$(call AddDepends/sound)
endef