summaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2015-08-15 15:10:14 +0000
committerZoltan Herpai <wigyori@uid0.hu>2015-08-15 15:10:14 +0000
commit1c66ebcd2db1e85590b11e0abc750eef25363328 (patch)
tree746f7c26f5414bbfe680e9574ec981437171de43 /target/linux/sunxi
parent56533842ce345b7d22aca5d74f027bb698be3067 (diff)
downloadmaster-31e0f0ae-1c66ebcd2db1e85590b11e0abc750eef25363328.tar.gz
master-31e0f0ae-1c66ebcd2db1e85590b11e0abc750eef25363328.tar.bz2
master-31e0f0ae-1c66ebcd2db1e85590b11e0abc750eef25363328.zip
sunxi: respect CONFIG_TARGET_IMAGES_GZIP
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 46608
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 10d2200aa3..5a5c98a7c0 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -45,6 +45,10 @@ define Image/Build/SDCard
$(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE) \
$(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
+
+ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+ gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img
+ endif
endef
define Image/Build/Profile/A10-OLinuXino-Lime