summaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/modules.mk
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2014-01-04 12:47:51 +0000
committerZoltan Herpai <wigyori@uid0.hu>2014-01-04 12:47:51 +0000
commit1ffc2deed468aa50456a97bee997545c3e4527bb (patch)
tree6d30a4bfd9bb90a3184a49dfa36d88982b856904 /target/linux/sunxi/modules.mk
parent662e5c224c82e0076f4debc60b1b85ce77648da2 (diff)
downloadmaster-31e0f0ae-1ffc2deed468aa50456a97bee997545c3e4527bb.tar.gz
master-31e0f0ae-1ffc2deed468aa50456a97bee997545c3e4527bb.tar.bz2
master-31e0f0ae-1ffc2deed468aa50456a97bee997545c3e4527bb.zip
sunxi: move rtc off to module
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 39195
Diffstat (limited to 'target/linux/sunxi/modules.mk')
-rw-r--r--target/linux/sunxi/modules.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
new file mode 100644
index 0000000000..8677a69494
--- /dev/null
+++ b/target/linux/sunxi/modules.mk
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+define KernelPackage/rtc-sunxi
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Sunxi SoC built-in RTC support
+ DEPENDS:=@TARGET_sunxi
+ $(call AddDepends/rtc)
+ KCONFIG:= \
+ CONFIG_RTC_CLASS=y \
+ CONFIG_RTC_DRV_SUNXI=m
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-sunxi.ko
+ AUTOLOAD:=$(call AutoLoad,50,rtc-sunxi)
+endef
+
+define KernelPackage/rtc-sunxi/description
+ Support for the AllWinner sunXi SoC's onboard RTC
+endef
+
+$(eval $(call KernelPackage,rtc-sunxi))
+