summaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/Makefile
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2013-11-14 23:12:52 +0000
committerZoltan Herpai <wigyori@uid0.hu>2013-11-14 23:12:52 +0000
commitf58bfd1df4e4a9b84a0e94691986c38bab6d8730 (patch)
tree9efce69525f7b07a108c03ba53b6721ebb1c8be2 /target/linux/sunxi/Makefile
parent2077361f128ff32dd6bb9fed7a4b3cd813863a9c (diff)
downloadmaster-31e0f0ae-f58bfd1df4e4a9b84a0e94691986c38bab6d8730.tar.gz
master-31e0f0ae-f58bfd1df4e4a9b84a0e94691986c38bab6d8730.tar.bz2
master-31e0f0ae-f58bfd1df4e4a9b84a0e94691986c38bab6d8730.zip
sunxi: rework target - update kernel to 3.12 - add patches for clocks, i2c, usb, sid, rtc - support common image for A10/A13/A20 - add support for a couple boards - most drivers are configured into the kernel as of now
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 38811
Diffstat (limited to 'target/linux/sunxi/Makefile')
-rw-r--r--target/linux/sunxi/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/target/linux/sunxi/Makefile b/target/linux/sunxi/Makefile
index e60f550360..658de40028 100644
--- a/target/linux/sunxi/Makefile
+++ b/target/linux/sunxi/Makefile
@@ -4,19 +4,26 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=sunxi
-BOARDNAME:=Allwinner SoC
-FEATURES:=targz
-SUBTARGETS=cortex-a7 cortex-a8
-MAINTAINER:=Luka Perkov <luka@openwrt.org>
+BOARDNAME:=Allwinner A1x/A20/A3x
+FEATURES:=fpu usb ext4 display
+CPU_TYPE:=cortex-a8
+CPU_SUBTYPE:=vfpv3
+MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.10.18
+LINUX_VERSION:=3.12
+KERNELNAME:="zImage dtbs"
+DEFAULT_PACKAGES += uboot-envtools uboot-sunxi
-include $(INCLUDE_DIR)/target.mk
+# A10: Cortex-A8
+# A13: Cortex-A8
+# A20: dual Cortex-A7
+# A31: quad Cortex-A7
-KERNELNAME:="zImage dtbs"
+include $(INCLUDE_DIR)/target.mk
$(eval $(call BuildTarget))