summaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-11-05 08:00:34 +0000
committerLuka Perkov <luka@openwrt.org>2013-11-05 08:00:34 +0000
commitcb07269988cd3be7cbbd3278081c5688ae8d7616 (patch)
tree140051364b271b5d49c01c572e3e534f7e0d0842 /target/linux/sunxi/Makefile
parentda224973af13644fb0b76d9422234a1f89e53134 (diff)
downloadmaster-31e0f0ae-cb07269988cd3be7cbbd3278081c5688ae8d7616.tar.gz
master-31e0f0ae-cb07269988cd3be7cbbd3278081c5688ae8d7616.tar.bz2
master-31e0f0ae-cb07269988cd3be7cbbd3278081c5688ae8d7616.zip
sunxi: add new target
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38651
Diffstat (limited to 'target/linux/sunxi/Makefile')
-rw-r--r--target/linux/sunxi/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/sunxi/Makefile b/target/linux/sunxi/Makefile
new file mode 100644
index 0000000000..bff78e5ee6
--- /dev/null
+++ b/target/linux/sunxi/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=sunxi
+BOARDNAME:=Allwinner SoC
+FEATURES:=targz
+SUBTARGETS=cortex-a7 cortex-a8
+MAINTAINER:=Luka Perkov <luka@openwrt.org>
+
+LINUX_VERSION:=3.10.17
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="zImage dtbs"
+
+$(eval $(call BuildTarget))