summaryrefslogtreecommitdiffstats
path: root/target/linux/storm/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-10-13 17:28:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-10-13 17:28:47 +0000
commit46d856ac86d3dd78d4d88cac9909ea773b3f1901 (patch)
treea78f2cdf35078cf628bddb4f5210610d68438496 /target/linux/storm/image
parenta1f36eaa949e95dde2538f2514d79db548ce7f29 (diff)
downloadmaster-31e0f0ae-46d856ac86d3dd78d4d88cac9909ea773b3f1901.tar.gz
master-31e0f0ae-46d856ac86d3dd78d4d88cac9909ea773b3f1901.tar.bz2
master-31e0f0ae-46d856ac86d3dd78d4d88cac9909ea773b3f1901.zip
change mtd partition map, use rootfs_split, and generate a firmware image for the WBD-111
SVN-Revision: 12976
Diffstat (limited to 'target/linux/storm/image')
-rw-r--r--target/linux/storm/image/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/target/linux/storm/image/Makefile b/target/linux/storm/image/Makefile
index b061c6d0ef..e94c463ec5 100644
--- a/target/linux/storm/image/Makefile
+++ b/target/linux/storm/image/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -19,23 +19,28 @@ define Image/BuildKernel
# BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
endef
-define Image/Build
- $(call Image/Build/$(1),$(1))
-endef
-
define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=64k conv=sync
endef
define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
- $(call Image/Build/slug,$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
endef
define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
- $(call Image/Build/slug,$(1))
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+
+ -$(STAGING_DIR_HOST)/bin/mkfwimage2 \
+ -m GEOS -f 0x30000000 -z \
+ -v WILI-S.WILIBOARD.v5.00.SL3512.OpenWrt.00000.000000.000000 \
+ -o $(BIN_DIR)/openwrt-$(BOARD)-wbd-111-$(1).bin \
+ -p Kernel:0x020000:0x100000:0:0:$(BIN_DIR)/openwrt-$(BOARD)-zImage \
+ -p Ramdisk:0x120000:0x500000:0:0:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)
endef
$(eval $(call BuildImage))