summaryrefslogtreecommitdiffstats
path: root/target/linux/sibyte/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-05-25 11:14:06 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-05-25 11:14:06 +0000
commit97c9af8df32034e5fde962491b8bfb6140e51f35 (patch)
tree726c2794c68433c6e3abdf60396b810e5532e76e /target/linux/sibyte/image
parent4cb9ba96121e774b1865d387fe08202436b923f1 (diff)
downloadmaster-31e0f0ae-97c9af8df32034e5fde962491b8bfb6140e51f35.tar.gz
master-31e0f0ae-97c9af8df32034e5fde962491b8bfb6140e51f35.tar.bz2
master-31e0f0ae-97c9af8df32034e5fde962491b8bfb6140e51f35.zip
sibyte image generation cleanup
SVN-Revision: 16046
Diffstat (limited to 'target/linux/sibyte/image')
-rw-r--r--target/linux/sibyte/image/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/target/linux/sibyte/image/Makefile b/target/linux/sibyte/image/Makefile
index 58c6bbd24b..d29a01900d 100644
--- a/target/linux/sibyte/image/Makefile
+++ b/target/linux/sibyte/image/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,12 +7,14 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-#define Image/Prepare
-# cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
-#endef
-
define Image/BuildKernel
cp $(LINUX_DIR)/vmlinux $(BIN_DIR)/openwrt-$(BOARD)-vmlinux
+# uImage
+ dd if=$(KDIR)/vmlinux of=$(KDIR)/openwrt-$(BOARD)-vmlinux bs=64k conv=sync
+ mkimage -A mips -O linux -T kernel -a 0x80100000 -C none -e \
+ 0x80100000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/openwrt-$(BOARD)-vmlinux $(BIN_DIR)/openwrt-$(BOARD)-uImage
endef
define Image/Build
@@ -29,9 +31,8 @@ define Image/Build/jffs2-128k
endef
define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
- $(call Image/Build/slug,$(1))
endef
$(eval $(call BuildImage))