summaryrefslogtreecommitdiffstats
path: root/target/linux/sibyte-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-14 16:41:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-14 16:41:33 +0000
commitbff468813f78f81e36ebb2a3f4354de7365e640f (patch)
treee0144a8d723cac2fd84505ec140dd0011541430a /target/linux/sibyte-2.6
parent7ca328b65927e12b4bb65a6d752f43b674498908 (diff)
downloadmaster-31e0f0ae-bff468813f78f81e36ebb2a3f4354de7365e640f.tar.gz
master-31e0f0ae-bff468813f78f81e36ebb2a3f4354de7365e640f.tar.bz2
master-31e0f0ae-bff468813f78f81e36ebb2a3f4354de7365e640f.zip
Upgrade to Linux 2.6.19
- Includes large parts of the patch from #1021 by dpalffy - Includes RB532 NAND driver changes by n0-1 SVN-Revision: 5789
Diffstat (limited to 'target/linux/sibyte-2.6')
-rw-r--r--target/linux/sibyte-2.6/Makefile4
-rw-r--r--target/linux/sibyte-2.6/patches/000-DUART.patch4
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/sibyte-2.6/Makefile b/target/linux/sibyte-2.6/Makefile
index 1b4fdfbc94..644927d19d 100644
--- a/target/linux/sibyte-2.6/Makefile
+++ b/target/linux/sibyte-2.6/Makefile
@@ -11,9 +11,9 @@ BOARD:=sibyte
BOARDNAME:=SiByte MIPS
FEATURES:=broken
-LINUX_VERSION:=2.6.17
+LINUX_VERSION:=2.6.19
LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+LINUX_KERNEL_MD5SUM:=443c265b57e87eadc0c677c3acc37e20
include $(INCLUDE_DIR)/kernel-build.mk
$(eval $(call BuildKernel))
diff --git a/target/linux/sibyte-2.6/patches/000-DUART.patch b/target/linux/sibyte-2.6/patches/000-DUART.patch
index fe899f1453..86b7666da6 100644
--- a/target/linux/sibyte-2.6/patches/000-DUART.patch
+++ b/target/linux/sibyte-2.6/patches/000-DUART.patch
@@ -54,7 +54,7 @@ diff -Nur linux-2.6.17/drivers/char/sb1250_duart.c linux-2.6.17-owrt/drivers/cha
+ * running in asynchronous mode. Also, support for doing a serial console
+ * on one of those ports
+ */
-+#include <linux/config.h>
++#include <linux/autoconf.h>
+#include <linux/types.h>
+#include <linux/kernel.h>
+#include <linux/serial.h>
@@ -267,7 +267,7 @@ diff -Nur linux-2.6.17/drivers/char/sb1250_duart.c linux-2.6.17-owrt/drivers/cha
+ * which port interrupted
+ */
+
-+static irqreturn_t duart_int(int irq, void *dev_id, struct pt_regs *regs)
++static irqreturn_t duart_int(int irq, void *dev_id)
+{
+ uart_state_t *us = (uart_state_t *)dev_id;
+ struct tty_struct *tty = us->tty;