summaryrefslogtreecommitdiffstats
path: root/target/linux/s3c24xx/patches-2.6.30/057-lis302dl.patch
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2009-05-18 17:55:41 +0000
committerLars-Peter Clausen <lars@metafoo.de>2009-05-18 17:55:41 +0000
commitf5affd4f36d839d706b02f1ffb69e0cf70c4140c (patch)
tree105a7093a2f5989136da5fe7128d6d95a3b9cad4 /target/linux/s3c24xx/patches-2.6.30/057-lis302dl.patch
parent267af10b33745d098198ad9c1d2b5ab69efb128f (diff)
downloadmaster-31e0f0ae-f5affd4f36d839d706b02f1ffb69e0cf70c4140c.tar.gz
master-31e0f0ae-f5affd4f36d839d706b02f1ffb69e0cf70c4140c.tar.bz2
master-31e0f0ae-f5affd4f36d839d706b02f1ffb69e0cf70c4140c.zip
bump to 2.6.30-rc6
SVN-Revision: 15918
Diffstat (limited to 'target/linux/s3c24xx/patches-2.6.30/057-lis302dl.patch')
-rw-r--r--target/linux/s3c24xx/patches-2.6.30/057-lis302dl.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/s3c24xx/patches-2.6.30/057-lis302dl.patch b/target/linux/s3c24xx/patches-2.6.30/057-lis302dl.patch
new file mode 100644
index 0000000000..df90f5f193
--- /dev/null
+++ b/target/linux/s3c24xx/patches-2.6.30/057-lis302dl.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.30-rc6/drivers/input/misc/Kconfig
+===================================================================
+--- linux-2.6.30-rc6.orig/drivers/input/misc/Kconfig 2009-05-18 19:07:07.000000000 +0200
++++ linux-2.6.30-rc6/drivers/input/misc/Kconfig 2009-05-18 19:08:33.000000000 +0200
+@@ -220,6 +220,15 @@
+ Say Y here if you want to support the built-in real time clock
+ of the HP SDC controller.
+
++config INPUT_LIS302DL
++ tristate "STmicro LIS302DL 3-axis accelerometer"
++ depends on SPI_MASTER
++ help
++ SPI driver for the STmicro LIS302DL 3-axis accelerometer.
++
++ The userspece interface is a 3-axis (X/Y/Z) relative movement
++ Linux input device, reporting REL_[XYZ] events.
++
+ config INPUT_PCF50633_PMU
+ tristate "PCF50633 PMU events"
+ depends on MFD_PCF50633
+Index: linux-2.6.30-rc6/drivers/input/misc/Makefile
+===================================================================
+--- linux-2.6.30-rc6.orig/drivers/input/misc/Makefile 2009-05-18 19:07:07.000000000 +0200
++++ linux-2.6.30-rc6/drivers/input/misc/Makefile 2009-05-18 19:08:33.000000000 +0200
+@@ -25,3 +25,4 @@
+ obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
+ obj-$(CONFIG_INPUT_YEALINK) += yealink.o
+ obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
++obj-$(CONFIG_INPUT_LIS302DL) += lis302dl.o