summaryrefslogtreecommitdiffstats
path: root/target/linux/s3c24xx/Makefile
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2008-12-12 00:02:36 +0000
committerMirko Vogt <mirko@openwrt.org>2008-12-12 00:02:36 +0000
commitb9dfb81f2aa45be745a8aed9684076210aed4152 (patch)
treeaceadd7f37096911a29c929988cbcf7c964a1c0b /target/linux/s3c24xx/Makefile
parent4571721ec22de116ad9998657e0a3c12da6405fb (diff)
downloadmaster-31e0f0ae-b9dfb81f2aa45be745a8aed9684076210aed4152.tar.gz
master-31e0f0ae-b9dfb81f2aa45be745a8aed9684076210aed4152.tar.bz2
master-31e0f0ae-b9dfb81f2aa45be745a8aed9684076210aed4152.zip
add support for target 3c24xx (more known as Openmoko GTA02 "Freerunner") and merge it with the openmoko-target and the work Michael Buesch <mb> did
SVN-Revision: 13609
Diffstat (limited to 'target/linux/s3c24xx/Makefile')
-rwxr-xr-xtarget/linux/s3c24xx/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/s3c24xx/Makefile b/target/linux/s3c24xx/Makefile
new file mode 100755
index 0000000000..66496fc9f8
--- /dev/null
+++ b/target/linux/s3c24xx/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=s3c24xx
+BOARDNAME:=s3c24xx
+FEATURES:=jffs2
+
+LINUX_VERSION:=2.6.26
+
+DEVICE_TYPE=phone
+
+define Target/Description
+ OpenMoko gta02
+endef
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += xglamo enlightenment
+
+$(eval $(call BuildTarget))