summaryrefslogtreecommitdiffstats
path: root/target/linux/realview
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-02-27 00:12:53 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-02-27 00:12:53 +0000
commit2d9ded9f2c5f3a223cfab2cfabb1cf4e8ec26dc6 (patch)
tree0481385695012684bee3ea7b6d5ad7a897f0a823 /target/linux/realview
parent0bf9032145a7db599b860105f814ede7c18662d9 (diff)
downloadmaster-31e0f0ae-2d9ded9f2c5f3a223cfab2cfabb1cf4e8ec26dc6.tar.gz
master-31e0f0ae-2d9ded9f2c5f3a223cfab2cfabb1cf4e8ec26dc6.tar.bz2
master-31e0f0ae-2d9ded9f2c5f3a223cfab2cfabb1cf4e8ec26dc6.zip
realview: fix zImage-initramfs installation
We were copying the actual vmlinux-initramfs.elf kernel which cannot be launched by QEMU or a real bootloader, use zImage-initramfs instead. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 39756
Diffstat (limited to 'target/linux/realview')
-rw-r--r--target/linux/realview/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/realview/image/Makefile b/target/linux/realview/image/Makefile
index dd0d9ee76d..c6ff8ce46a 100644
--- a/target/linux/realview/image/Makefile
+++ b/target/linux/realview/image/Makefile
@@ -8,7 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
- cp $(LINUX_DIR)/arch/$(ARCH)/boot/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ cp $(KDIR)/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+define Image/BuildKernel/Initramfs
+ cp $(KDIR)/$(subst ",,$(KERNELNAME))-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
endef
define Image/Build/squashfs