summaryrefslogtreecommitdiffstats
path: root/target/linux/realview
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-27 15:34:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-27 15:34:38 +0000
commit0cce8316d9d2b7872d64206c9e9d270b4895b6f8 (patch)
treeb62c2ba7b315b63a475230a95fb71d46bfc8d936 /target/linux/realview
parentf2a75b6ca4710697579e9ba2cfe51526a5c34fab (diff)
downloadmaster-31e0f0ae-0cce8316d9d2b7872d64206c9e9d270b4895b6f8.tar.gz
master-31e0f0ae-0cce8316d9d2b7872d64206c9e9d270b4895b6f8.tar.bz2
master-31e0f0ae-0cce8316d9d2b7872d64206c9e9d270b4895b6f8.zip
realview: use common image prefix
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45787
Diffstat (limited to 'target/linux/realview')
-rw-r--r--target/linux/realview/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/realview/image/Makefile b/target/linux/realview/image/Makefile
index 1f3fa4a664..28db6f330c 100644
--- a/target/linux/realview/image/Makefile
+++ b/target/linux/realview/image/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
- cp $(KDIR)/$(KERNELNAME) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ cp $(KDIR)/$(KERNELNAME) $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
endef
define Image/BuildKernel/Initramfs
- cp $(KDIR)/$(KERNELNAME)-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
+ cp $(KDIR)/$(KERNELNAME)-initramfs $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
endef
define Image/Build/squashfs
@@ -21,7 +21,7 @@ endef
define Image/Build
$(call Image/Build/$(1))
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
endef
$(eval $(call BuildImage))