summaryrefslogtreecommitdiffstats
path: root/target/linux/realview/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-11-08 07:31:36 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-11-08 07:31:36 +0000
commit5d28877c92b9e80be095fa0c2692b24a28cdafb6 (patch)
treefc2a551a931d2a252ef77b310bd65d8ac622fc0f /target/linux/realview/Makefile
parent6a61d2d905837736644acef39ce2f688764e5707 (diff)
downloadmaster-31e0f0ae-5d28877c92b9e80be095fa0c2692b24a28cdafb6.tar.gz
master-31e0f0ae-5d28877c92b9e80be095fa0c2692b24a28cdafb6.tar.bz2
master-31e0f0ae-5d28877c92b9e80be095fa0c2692b24a28cdafb6.zip
add qemu target
SVN-Revision: 23921
Diffstat (limited to 'target/linux/realview/Makefile')
-rw-r--r--target/linux/realview/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
new file mode 100644
index 0000000000..546fa9d347
--- /dev/null
+++ b/target/linux/realview/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=realview
+BOARDNAME:=ARM Ltd Realview
+FEATURES:=squashfs jffs2 fpu
+CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
+
+LINUX_VERSION:=2.6.36
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build images for ARM Ltd Realview boards to be run with qemu
+endef
+
+KERNELNAME:="zImage"
+
+$(eval $(call BuildTarget))