summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-10-15 16:13:25 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-10-15 16:13:25 +0000
commit9dc51096e6359769946224ea5ce03a88c14c8b8a (patch)
tree459de6073c767dbb4f50ad3b26dc0d7ce060ae60 /target/linux/rdc
parent8c96b88b250762afe423dda14af59138baae1949 (diff)
downloadmaster-31e0f0ae-9dc51096e6359769946224ea5ce03a88c14c8b8a.tar.gz
master-31e0f0ae-9dc51096e6359769946224ea5ce03a88c14c8b8a.tar.bz2
master-31e0f0ae-9dc51096e6359769946224ea5ce03a88c14c8b8a.zip
Add the RDC PCI ids for a fancier PCI device table.Return the system name on boot.
SVN-Revision: 9327
Diffstat (limited to 'target/linux/rdc')
-rw-r--r--target/linux/rdc/files/arch/i386/mach-rdc/Makefile2
-rw-r--r--target/linux/rdc/files/arch/i386/mach-rdc/setup.c14
-rw-r--r--target/linux/rdc/patches/004-rdc_fixes.patch2
-rw-r--r--target/linux/rdc/patches/006-pci_ids.patch18
4 files changed, 34 insertions, 2 deletions
diff --git a/target/linux/rdc/files/arch/i386/mach-rdc/Makefile b/target/linux/rdc/files/arch/i386/mach-rdc/Makefile
index 5961bc7910..07a92038d0 100644
--- a/target/linux/rdc/files/arch/i386/mach-rdc/Makefile
+++ b/target/linux/rdc/files/arch/i386/mach-rdc/Makefile
@@ -1,5 +1,5 @@
#
# Makefile for the RDC321x specific parts of the kernel
#
-obj-$(CONFIG_X86_RDC) := gpio.o platform.o wdt.o
+obj-$(CONFIG_X86_RDC) := gpio.o platform.o wdt.o setup.o
diff --git a/target/linux/rdc/files/arch/i386/mach-rdc/setup.c b/target/linux/rdc/files/arch/i386/mach-rdc/setup.c
new file mode 100644
index 0000000000..ad206c3d05
--- /dev/null
+++ b/target/linux/rdc/files/arch/i386/mach-rdc/setup.c
@@ -0,0 +1,14 @@
+/*
+ * Machine specific setup for generic
+ */
+
+#include <linux/init.h>
+#include <linux/interrupt.h>
+#include <asm/arch_hooks.h>
+#include <asm/io.h>
+#include <asm/setup.h>
+
+char * __init machine_specific_memory_setup(void)
+{
+ return "RDC R-321x";
+}
diff --git a/target/linux/rdc/patches/004-rdc_fixes.patch b/target/linux/rdc/patches/004-rdc_fixes.patch
index 524155adf6..e67678a8e8 100644
--- a/target/linux/rdc/patches/004-rdc_fixes.patch
+++ b/target/linux/rdc/patches/004-rdc_fixes.patch
@@ -67,7 +67,7 @@ diff -urN linux-2.6.19/arch/i386/Makefile linux-2.6.19.new/arch/i386/Makefile
};
static struct device_fixup fixups_table[] = {
-+{ 0x17F3, 0x6030, r8610_reset },
++{ PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_R6030, r8610_reset },
{ PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
{ PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
};
diff --git a/target/linux/rdc/patches/006-pci_ids.patch b/target/linux/rdc/patches/006-pci_ids.patch
new file mode 100644
index 0000000000..cd4c01d920
--- /dev/null
+++ b/target/linux/rdc/patches/006-pci_ids.patch
@@ -0,0 +1,18 @@
+diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
+index 55f307f..4a1aa34 100644
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -2076,6 +2076,13 @@
+ #define PCI_DEVICE_ID_HERC_WIN 0x5732
+ #define PCI_DEVICE_ID_HERC_UNI 0x5832
+
++#define PCI_VENDOR_ID_RDC 0x17f3
++#define PCI_DEVICE_ID_RDC_R6020 0x6020
++#define PCI_DEVICE_ID_RDC_R6030 0x6030
++#define PCI_DEVICE_ID_RDC_R6040 0x6040
++#define PCI_DEVICE_ID_RDC_R6060 0x6060
++#define PCI_DEVICE_ID_RDC_R6061 0x6061
++
+ #define PCI_VENDOR_ID_SITECOM 0x182d
+ #define PCI_DEVICE_ID_SITECOM_DC105V2 0x3069
+