summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/profiles
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-10-28 18:54:35 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-10-28 18:54:35 +0000
commit40c7588db0dd14e90d2522d397f1977fbe8e6d90 (patch)
treeb492f42f755d29bffaab61dd012e8434c5461afb /target/linux/rdc/profiles
parent5f9b69cfc69d0a20c50a5f4d4d91805e6f263a9c (diff)
downloadmaster-31e0f0ae-40c7588db0dd14e90d2522d397f1977fbe8e6d90.tar.gz
master-31e0f0ae-40c7588db0dd14e90d2522d397f1977fbe8e6d90.tar.bz2
master-31e0f0ae-40c7588db0dd14e90d2522d397f1977fbe8e6d90.zip
Update kernel configuration and add profiles and per-profile kernel configuration files for AMIT and Zyxel boards, thanks sn9
SVN-Revision: 13064
Diffstat (limited to 'target/linux/rdc/profiles')
-rw-r--r--target/linux/rdc/profiles/AMIT.mk13
-rw-r--r--target/linux/rdc/profiles/G-570S.mk13
2 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/rdc/profiles/AMIT.mk b/target/linux/rdc/profiles/AMIT.mk
new file mode 100644
index 0000000000..2e3d873847
--- /dev/null
+++ b/target/linux/rdc/profiles/AMIT.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/amit
+ NAME:=Devices from AMIT
+ PACKAGES:=kmod-r6040 kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+$(eval $(call Profile,amit))
+
diff --git a/target/linux/rdc/profiles/G-570S.mk b/target/linux/rdc/profiles/G-570S.mk
new file mode 100644
index 0000000000..4cb9bd9a94
--- /dev/null
+++ b/target/linux/rdc/profiles/G-570S.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/g570s
+ NAME:=ZyXEL G-570S
+ PACKAGES:=kmod-madwifi kmod-r6040
+endef
+$(eval $(call Profile,g570s))
+