summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/profiles/r8610.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-25 10:13:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-25 10:13:00 +0000
commit821bd49569acf55cc6489c762dc279f6da838dee (patch)
tree397901ecc16c129354cb037dac2ea1833855bdcb /target/linux/rdc/profiles/r8610.mk
parent35bb7be34d30252059144c1855f7397695b9362c (diff)
downloadmaster-31e0f0ae-821bd49569acf55cc6489c762dc279f6da838dee.tar.gz
master-31e0f0ae-821bd49569acf55cc6489c762dc279f6da838dee.tar.bz2
master-31e0f0ae-821bd49569acf55cc6489c762dc279f6da838dee.zip
use profiles again intead of subtargets.
We have now a single kernel which autodetects the type of device we are running on, so we can switch back to having profiles. Patch by Bernhard Loos. SVN-Revision: 20416
Diffstat (limited to 'target/linux/rdc/profiles/r8610.mk')
-rw-r--r--target/linux/rdc/profiles/r8610.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/rdc/profiles/r8610.mk b/target/linux/rdc/profiles/r8610.mk
new file mode 100644
index 0000000000..67fef8a5ae
--- /dev/null
+++ b/target/linux/rdc/profiles/r8610.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/r8610
+ NAME:=RDC R8610 Evaluation Board
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-hwmon-core kmod-hwmon-w83627hf kmod-ide-core kmod-ide-it821x \
+ kmod-rtc-core kmod-rtc-m48t86 \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+$(eval $(call Profile,r8610))