summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/patches-2.6.32/008-r8610_flash_map.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-02-23 21:09:51 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-02-23 21:09:51 +0000
commitb57690432c90c356d3f2d6edd3bbc565dc72a61c (patch)
tree9203a7ccef0119d0922f343766a8ac7a323b9d16 /target/linux/rdc/patches-2.6.32/008-r8610_flash_map.patch
parent3e139467ce44c9522592aad80b8989f6a923c79c (diff)
downloadmaster-31e0f0ae-b57690432c90c356d3f2d6edd3bbc565dc72a61c.tar.gz
master-31e0f0ae-b57690432c90c356d3f2d6edd3bbc565dc72a61c.tar.bz2
master-31e0f0ae-b57690432c90c356d3f2d6edd3bbc565dc72a61c.zip
add preliminary 2.6.32 support
SVN-Revision: 19826
Diffstat (limited to 'target/linux/rdc/patches-2.6.32/008-r8610_flash_map.patch')
-rw-r--r--target/linux/rdc/patches-2.6.32/008-r8610_flash_map.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/rdc/patches-2.6.32/008-r8610_flash_map.patch b/target/linux/rdc/patches-2.6.32/008-r8610_flash_map.patch
new file mode 100644
index 0000000000..0f06beb090
--- /dev/null
+++ b/target/linux/rdc/patches-2.6.32/008-r8610_flash_map.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -158,6 +158,12 @@ config MTD_RDC3210_BUSWIDTH
+ Number of bytes addressed on the RDC-3210 flash device before
+ addressing the same chip again
+
++config MTD_R8610
++ tristate "CFI flash device mapped on R8610"
++ depends on X86 && MTD_CFI && MTD_PARTITIONS
++ help
++ Flash support for the RDC R8610 evaluation board.
++
+ config MTD_SC520CDP
+ tristate "CFI Flash device mapped on AMD SC520 CDP"
+ depends on X86 && MTD_CFI && MTD_CONCAT
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -27,6 +27,7 @@ obj-$(CONFIG_MTD_PHYSMAP_OF) += physmap_
+ obj-$(CONFIG_MTD_PMC_MSP_EVM) += pmcmsp-flash.o
+ obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
+ obj-$(CONFIG_MTD_RDC3210) += rdc3210.o
++obj-$(CONFIG_MTD_R8610) += r8610.o
+ obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
+ obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
+ obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o