summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/patches-2.6.30/008-r8610_flash_map.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-08-05 13:48:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-08-05 13:48:22 +0000
commit1349acd7ec046908e81ac21e8a9d07ca780aa5a2 (patch)
tree67b0b33bd7217dd29093d71e1b3e0532901ab46f /target/linux/rdc/patches-2.6.30/008-r8610_flash_map.patch
parent95a498251e20de17ec22dccb74360b5ff1858356 (diff)
downloadmaster-31e0f0ae-1349acd7ec046908e81ac21e8a9d07ca780aa5a2.tar.gz
master-31e0f0ae-1349acd7ec046908e81ac21e8a9d07ca780aa5a2.tar.bz2
master-31e0f0ae-1349acd7ec046908e81ac21e8a9d07ca780aa5a2.zip
add experimental support for 2.6.30
SVN-Revision: 17131
Diffstat (limited to 'target/linux/rdc/patches-2.6.30/008-r8610_flash_map.patch')
-rw-r--r--target/linux/rdc/patches-2.6.30/008-r8610_flash_map.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/rdc/patches-2.6.30/008-r8610_flash_map.patch b/target/linux/rdc/patches-2.6.30/008-r8610_flash_map.patch
new file mode 100644
index 0000000000..e0ccb83ccc
--- /dev/null
+++ b/target/linux/rdc/patches-2.6.30/008-r8610_flash_map.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.29.5/drivers/mtd/maps/Kconfig
+===================================================================
+--- linux-2.6.29.5.orig/drivers/mtd/maps/Kconfig 2009-06-19 11:26:44.000000000 +0200
++++ linux-2.6.29.5/drivers/mtd/maps/Kconfig 2009-06-19 11:26:45.000000000 +0200
+@@ -167,6 +167,12 @@
+ Number of bytes addressed on the RDC-3210 flash device before
+ addressing the same chip again
+
++config MTD_R8610
++ tristate "CFI flash device mapped on R8610"
++ depends on X86 && MTD_CFI && MTD_PARTITIONS
++ help
++ Flash support for the RDC R8610 evaluation board.
++
+ config MTD_SC520CDP
+ tristate "CFI Flash device mapped on AMD SC520 CDP"
+ depends on X86 && MTD_CFI && MTD_CONCAT
+Index: linux-2.6.29.5/drivers/mtd/maps/Makefile
+===================================================================
+--- linux-2.6.29.5.orig/drivers/mtd/maps/Makefile 2009-06-19 11:26:44.000000000 +0200
++++ linux-2.6.29.5/drivers/mtd/maps/Makefile 2009-06-19 11:26:45.000000000 +0200
+@@ -28,6 +28,7 @@
+ obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcmsp-ramroot.o
+ obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
+ obj-$(CONFIG_MTD_RDC3210) += rdc3210.o
++obj-$(CONFIG_MTD_R8610) += r8610.o
+ obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
+ obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
+ obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o